Please help with restarting the Google Simulator

I had Google Assistant integration set up and working. It’s my understanding that the Google project expires after a month, after which one needs to restart the simulation. My issue is I have no idea how to do this! I’m at the Google Actions page, on the “Test” tab. I can see the simulator page. How do I start the simulator? It seems that whatever command I enter, I get an “Invocation error” saying “You cannot use standard Google Assistant features in the Simulator. If you want to try them, use Google Assistant on your phone or other compatible devices.”

When I tell my Google Home Speaker to “Talk to Isaac” (Isaac is my project name) it just says that it doesn’t understand.

See here in the simulator top bar:

It says test is enabled

Thanks! I think I started the simulation properly as Google now responds to the “sync my devices” command. I’m still running into trouble though. I have unlinked and relinked my test account in the Google Home app but only one of my lights is responding. Not sure why the other ones won’t respond…

I had all kinds of trouble yesterday… Google said at least every second time it wouldn’t talk with the test app. effing frustrating… but I think it’s a Google problem. (today seems fine)

Now only 1 light responding?? Well that sounds like config to me… what does your config look like? In the Google Home app, does it show all the devices correctly?

Here’s my config. So far only the Kitchen Lights are responding. Every other light, Google says it can’t connect to the light.

  project_id: [redacted]
  api_key: [redacted]
    - light
    # - media_player
      room: Kitchen
      room: Kitchen
      room: Kitchen
      room: Family Room
      room: Family Room
      room: Front Yard
      room: Family Room
        - Flood Lights
        - Pot Lights
      room: Family Room

Do they show up in the Google Home App though?
When you say Kitchen Lights - are you referring to the room (which has 3 lights)?

Wow, now they all seem to be working fine. I guess I’ll just chalk it up to Google being dumb.

I literally just gave the same command to it twice. It failed the first time and worked the second time.

Can’t help but wonder if Alexa integration is any better!

Thanks for your help, much appreciated!

1 Like


Yeah… go figure… as I said some weird shit for me yesterday where it’s been pretty much flawless for over a year…

Just wanted to add that I’ve also had some problems with my google home devices not being able to connect to the custom integration this week. The assistant sometimes responds with something like “Sorry, I couldn’t reach home assistant”. Usually if I ask it a second time right after, it works fine. The other day I had to ask multiple times, though.

I hope this is a temporary problem… There have been a lot of bugs in the google home ecosystem this week and if they don’t get resolved quickly I’m going to be pretty upset!

Are there any good alternatives to Google Home that don’t rely on sending commands out into the cloud? Some kind of local voice command app that just functions on the home network?

If this keeps up I’m going to want to switch.

You could try this.

Yep. I had to ask 20 times last night before it worked.