Please provide an example for working Vera Configuration

Can somebody please provide an simple configuration.yaml example for a working Vera hub. After reading that Vera is supported by HASS I purchased the Vera Plus hub on local network port 80 (installed latest firmware 1.7.2044) and setup some lights and a couple sensors on it. I’ve verified the Vera web interface works well. The documentation makes it seem that the Vera component is a simple setup but I’ve tried many things in the .yaml file and it never loads the components.

I am running Home Assistant 0.25.2 on a Raspberry Pi 3with Raspbian Jessie. I have experience with RPis and linux in general but not with .yaml file formats. I am using the suggested entry below to no avail…

vera:
  vera_controller_url: http://192.168.1.91:80/

Please help provide a full config file with Vera, thanks!

Try with port 3480 instead of 80.

//Jocke

Thanks Jocke, I have tried with port 3480, still no joy. When I access the portal for my Vera controller, it redirects me to http://192.168.1.91/cmh . I’m wondering if this is creating an issue with the HASS config. Thoughts?

Is there any related error in log?

OK, for any others who encounter this error, I was able to get it working. I had some extra config items listed below the vera config line that I removed to simplify it. I also found that after making changes in the yaml file, it seems the best sequence is to 1. reload_core_config and then 2. restart the service. At least on my RPi, that was the most reliable way to reload the config info… not sure why.

Thanks again Jocke, turns out the simple example using port 3480 placed at the end of the .yaml file was indeed correct. Now on to more advanced tweaking.

Hi, I am trying to get the same situation with my Vera Plus. There is no port listed and when I enter the IP address of the vera and add :3480 to the URL it just does not even go to the IP address.
Any ideas?
How would it even get my user name and password if I don’t pass it onto the Vera?
I have added the following in my configuration.yaml file

vera:
vera_controller_url: http://http://192.168.1.67/

^^^
I’m having the same problem, can someone provide a solution?

2019-12-04 17:22:18 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.1916905424] Error handling message: expected str for dictionary value @ data[‘service’]. Got None

If anyone stumbles on to this it should be entered as:

> vera:
>   vera_controller_url: http://192.168.xxx.xxx/port_3480

where xxx is your vera controller IP address. You can enter this into the integration wizard for Vera.

http://192.168.xxx.xxx/port_3480

4 Likes

Thank you.