Plex Activity Monitor

I am attempting to get the Plex Activity Monitor up and running, but am running into errors showing up in the log and no sensor showing up in HASS. When I configure it without a user and password, in addition to all the errors below I also get 401: unauthorized, even though it is on my local network. When set up with a user and pass in the config, below is my erro log…

16-09-27 12:06:00 homeassistant.components.media_player: Error while setting up platform plex
Traceback (most recent call last):
File “/srv/hass/lib/python3.4/site-packages/homeassistant/helpers/”, line 107, in _setup_platform
File “/srv/hass/lib/python3.4/site-packages/homeassistant/components/media_player/”, line 66, in setup_platform
config = config_from_file(hass.config.path(PLEX_CONFIG_FILE))
File “/srv/hass/lib/python3.4/site-packages/homeassistant/components/media_player/”, line 54, in config_from_file
return json.loads(
File “/usr/lib/python3.4/json/”, line 318, in loads
return _default_decoder.decode(s)
File “/usr/lib/python3.4/json/”, line 343, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File “/usr/lib/python3.4/json/”, line 361, in raw_decode
raise ValueError(errmsg(“Expecting value”, s, err.value)) from None
ValueError: Expecting value: line 1 column 1 (char 0)
16-09-27 12:06:03 homeassistant.components.sensor: Error while setting up platform plex
Traceback (most recent call last):
File “/srv/hass/lib/python3.4/site-packages/homeassistant/helpers/”, line 107, in _setup_platform
File “/srv/hass/lib/python3.4/site-packages/homeassistant/components/sensor/”, line 51, in setup_platform
name, plex_url, plex_user, plex_password, plex_server)])
File “/srv/hass/lib/python3.4/site-packages/homeassistant/components/sensor/”, line 70, in init
user = MyPlexAccount.signin(plex_user, plex_password)
AttributeError: type object ‘MyPlexAccount’ has no attribute ‘signin’

Any help would be greatly appreciated!!!

Not sure how much I can help but I did set this up myself just now. After some bumps along the way I was able to get it working. My server is on the same machine that I am running HASS but I still ended up having to use the username and password. However, it is not the U & P I use to login to . At some point I apparently configured a local account that I never use. Once I figured out that account information it worked fine for me.

Another thing you can try is this. In your Plex server settings go to Server -> Network . At the bottom there is the option for “List of IP addresses and networks that are allowed without auth” . You can try adding the IP of your HASS instance to that list.

Finally, if those suggestions don’t work I would recommend posting a scrubbed version of the Plex section of your config.

Here’s my config lines from my sensors.yaml

  - platform: plex
    name: Plex
    port: 32400
    username: !secret plex_user
    password: !secret plex_pass
    server: zeus

I added my raspi that is running hass to the authorized section in Plex setup Server -> Network. Still no love.

Are you able to loginto using the username and password you have in the config? If I remember right mine will not find anything to monitor if I have the wrong plex token in the mediaplayer config for plex. this for me is another file plex.conf