❱ Plex Assistant

ok, when i logon on plex, if i look at “authorized devices” i can see the name of my samsung tv, with the cast bundle installed
so i try this :
command: play finding nemo on the TV UE32H5500

=> result it plays “mission impossible” on some random google mini in my house :slight_smile:

I just haven’t made a release with that fix in it yet, waiting to get some other features/fixes in before then.

Yup, sounds like pychromecast can’t find the device. I’ll see what I can do to implement support for the flextv.bundle plugin. Can you try the following URLs and let me know if your TV is listed in any of them and if so which one(s):


yes, has been found :

<MediaContainer title1="Flex TV" noHistory="1" viewmode="65592" contenttype="items" noCache="1" size="5" identifier="com.plexapp.plugins.FlexTV" sourceTitle="Flex TV" mediaTagPrefix="/system/bundle/media/flags/">

<Directory thumb="/:/plugins/com.plexapp.plugins.FlexTV/resources/icon-cast_video.png?t=1571205822" title="Google Bureau" tagline="" key="/stats/sessions?input_name=Google+Bureau" duration="1"/>

<Directory thumb="/:/plugins/com.plexapp.plugins.FlexTV/resources/icon-cast_video.png?t=1571205822" title="Google Hub" tagline="" summary="Plex" key="/stats/sessions?input_name=Google+Hub" duration="1"/>

<Directory thumb="/:/plugins/com.plexapp.plugins.FlexTV/resources/icon-cast_video.png?t=1571205822" title="Google Badkamer" tagline="" key="/stats/sessions?input_name=Google+Badkamer" duration="1"/>

<Directory thumb="/:/plugins/com.plexapp.plugins.FlexTV/resources/icon-cast_video.png?t=1571205822" title="Chromecast" tagline="" key="/stats/sessions?input_name=Chromecast" duration="1"/>

<Directory thumb="/:/plugins/com.plexapp.plugins.FlexTV/resources/icon-plex_client.png?t=1571205822" title="TV UE55H6400" tagline="" summary="Plex Client" key="/stats/sessions?input_name=TV+UE55H6400" duration="n/a"/>

<MediaContainer size="5" version="1.1.106">

<Device status="True" name="Google Bureau" uri="" type="cast" id=""/>

<Device status="True" name="Google Hub" app="Plex" uri="" type="cast" id=""/>

<Device status="True" name="Google Badkamer" uri="" type="cast" id=""/>

<Device status="True" name="Chromecast" uri="" type="cast" id=""/>

<Device status="n/a" name="TV UE55H6400" app="Plex Client" uri="" type="Plex for Samsung" id="mtcjs3w774g7i"/>

<MediaContainer size="4" version="1.1.106">

<Device status="True" name="Google Bureau" uri="" type="cast" id=""/>

<Device status="True" name="Google Hub" app="Plex" uri="" type="cast" id=""/>

<Device status="True" name="Google Badkamer" uri="" type="cast" id=""/>

<Device status="True" name="Chromecast" uri="" type="cast" id=""/>


seems i entered the wrong name …
also under devices , the samsung is not listed, only under resources/clients

ok, so i now tried :
command: play finding dory on the TV UE55H6400

but it played, some random movie of lord of the rings on a google mini

Yeah, that would be because it can’t find “TV UE55H6400” as a device so then it assumes that it must be part of the media’s title. This is needed so when trying to play “Murder on the Orient Express” or any movie with “on the” in the title it doesn’t get confused.

So, it’s looking for media closest to the name “finding dory on the TV UE55H6400” instead of “finding dory” and since you haven’t set a default device I would assume it’s just picking the first in the list that it finds.

ok, so it doesnt help if i put it in the config.yaml? i commented out that default_cast line
you need to do spmething to make it work (flex.tv bundle) ??

anyway gonna try some testing with the google hub instead now :slight_smile:

hmm, i now tried this:

command: play finding nemo on the google hub

but it also plays “mission impossible” on the hub? :slight_smile:

Right, I would have to add support for the flex tv plugin for this to work. What worries me is the fact that the API returns a self assigned IP address for your TV ( which isn’t very helpful. When using flexTV before did you need the plex app open on your TV for it to work?

Are you sure “Finding Nemo” is in your library?

yeah, finding nemo and finding dory are the favorite movies for my kids :slight_smile:
they are indeed in a kids library
edit: wait, i know the issue maybe, when i use:
command: play avangers endgame on the google hub
that works
seems my kids library is a "other video"s library instead of a “movies” library

and yes, when i was using Flex.Tv before, the plex app needed to be open on the samsung tv

See this issue for the other libraries. Working on it.

I’ll see what I can do to try and support this, but this would require that devices are refreshed with every command sent. Need to see how much of a delay this would add.

hehe, same quesion
ok, subscribed no big deal
i can delete that custom library and receate again
dont know why i did create a custom one before, dont know the difference anymore

ok, started with ifttt
tell plex to play terminator on google hub => command receives, but it starts on a google mini instead of the “google hub” , what am i doing wrong?

also if i say , tell plex to stop, i see it stops, then it plays again …

sorry i needed to use “on the”

then it works :slight_smile:

1 Like

The phrase to play on a device should be “on the”, there would be too many false positives if it was just “on”.

I haven’t built in any stop, pause, next, etc commands yet as you can usually just say “hey google stop”, “hey google pause”, etc. without having to say “tell plex”. I do plan to build those in at some point.

There is also a built in method that avoids a bug with plex where it can cause a blank screen. The fix for it is to essentially tell it to play the item multiple times. This can make it so if you tell something to play and then immediately tell it to stop it will play again, but if you wait a second or 2 after starting a show before telling it to stop then it will stop just fine.

ah ok, clear!!

anyway, if i need to todo/test something with my samsung, let me know
for now i am testing on the hub, gonna try also in my native dutch language now

no one has made translations in dutch for this component yet, so I’m not sure how far you’ll get with that :wink:

well, seems to work
i can say : “speel terminator 2 op de google hub”
that works :slight_smile:
so do i need todo something?

Well that means one of two things. Either IFTTT is automatically translating from a language it claims it doesn’t have support for (not likely) or the “fuzzy” matching in the component is doing a much better job than i thought it would.

Continue to test, but I think it might have trouble at some point especially with playing to different devices. When I get time I can work with you to see if there is some built in translation somewhere, but I’m doubtful.

yea, i think google is indeed doing the translation, not ifttt
because i have setup everything in dutch on my google devices, also no secundary language active, and i can still activate switches/webhooks/scripts in english …

Try things like “unwatched”, “on deck”, or “season 1 episode 3”