Plex sensor fails: "plex: Error on device update!"

I’m new to HA. I’ve been playing in it for couple of weeks now.
When I was on version 0.65.6, Plex sensor and player were fine and working.
I upgraded to 0.66.0b3 (pre) because I couldn’t wait to have homekit filters.

Now, since 0.66 is out, I upgraded to it (stable)
Everything seems fine EXCEPT plex sensor…
The Plex media player component works great though…

When I start HA, I get this:
plex: Error on device update!
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/”, line 188, in _async_add_entity
await entity.async_device_update(warning=False)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/”, line 327, in async_device_update
yield from self.hass.async_add_job(self.update)
File “/usr/lib/python3.5/asyncio/”, line 380, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.5/asyncio/”, line 304, in _wakeup
File “/usr/lib/python3.5/asyncio/”, line 293, in result
raise self._exception
File “/usr/lib/python3.5/concurrent/futures/”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/util/”, line 319, in wrapper
result = method(*args, **kwargs)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/sensor/”, line 131, in update
season_episode += " · E{1}".format(sess.index)
IndexError: tuple index out of range

The token is valid (and since player works, it kind of confirms it)

Hope someone can help…
Thanks in advance!

Stooped working for me as well

I’m still not 100% sure but, based on what I saw on my Plex monitoring (Tautilli) and Plex activities, this happened when there was a remote user playing from a Vizio TV…
Now, it works and this client isn’t used…

Still looking into it but it might hint someone else where to look (a specific plex client platform playing something)
Again, really not sure… Might be completely off track here…

I’m getting the same since updating to v 0.66.1 from 0.65 . Same error. I’ve been using the Plex sensor for quite a while now and haven’t made any changes to it.

Edit: Opened up a issue on the github repo so if anyone else is having this issue feel free to add your logs and config to it as well: