As the subject says, I’ve had no issues with 2026.8.1 and normally use Portainer for container management. I’m on a slow internet connection so normally large docker pulls will timeout before they complete. My workaround has been to use skopeo to download images manually then upload to HA via the Portainer addon (yes, janky but it’s worked for years).
For some reason I can no longer upload images via Portainer as it’s throwing a 502 bad gateway error. I am not using nginx or other proxy service but understand nginx is used internally by HA. No changes in my configuration or network for months so unsure what changed (in the proxy) between the last time I updated and 2026.8.1. Nothing in the logs other than the 502 error although I am also seeing “Unable to upload image: Forbidden”. Cleared cache and cookies, fully rebooted HA, logged back in and same error. Plenty of space on dedicated HA platform (RPi CM4 IOBoard build), no changes in credentials and I can log in. Anyone have any suggestions?
Traffic loads to home-assistant.io are being buffered by CloudFlare and are recently experiencing heavy loads. It may be a DDOS on their infrastructure, or just over-enthusiastic AI bots scraping the site for ever changing new content.
Maybe it is something outside your control?
Good hypothesis but I have the update files locally and am getting the 502 when uploading to my HA instance within my network. I assume this is something wonky with the HA install of Nginx but I’m at a loss on troubleshooting since I’m unclear what the root cause might be. Everything is running normally with the exception of Portainer import/uploads.
Saw this in the logs:
2026/08/27 12:30AM ERR github.com/portainer/portainer/api/http/csrf/csrf.go:58 > CSRF check failed: unsafe cookie-authenticated request without Origin or Sec-Fetch-Site headers, set CSRF_ALLOW_NO_ORIGIN=1 to allow such requests | host=192.xxx.xxx.xxx:8123 method=POST request_url=/api/endpoints/1/docker/v1.47/images/load
So, under Portainer → Configuration I add a env_vars for CSRF_ALLOW_NO_ORIGIN with a value of 1, restarted, and problem solved.
Glad you found the fix.
Is this a problem with the documentation not being clear, the Portainer default settings being incorrect, or something else? Other than stumbling across this thread, will others encountering the same issue be able to easily remedy it?