Possible to disable RBG support and turn it into a dimmer?

Hello! I have a Fibaro RBGW-unit connected to a white LED-strip, thus using only one channel.
Everything has been working fine until I tried using the scenes editor which keeps setting values like hs_color, rgb_color and xy_color. This makes the Fibaro unit turn off until I make a hard reset (possibly because some overload due to no lights being connected to the other channels). Setting brightness in the Lovelace UI works fine otherwise.

In hindsight I should have bought a plain dimmer unit, but is there some way to configure the zwave component or home assistant entity registry to make HA think this fibaro rgbw is a standard led-dimmer to solve the problem with the scenes editor setting RGB-values?

Just to disable the RGB-support and make this entity appear as any other dimmed light source with only brightness control…

Why don’t you just remove the hs_color, rgb_color etc. manually from the scene after you created it or are you creating scenes on the fly?

I’m trying to use the scene editor, and it keeps putting these values back every time the scene is changed.

Sorry, I don’t use scenes so can’t speak from direct experience but Burning’s suggestion could be modified if you have the “LED dimmer setting” that you want (it can’t change can it if you are just setting a level for a particular scene ?). Then you can copy that ‘portion’ as a snippet and re-integrate it whenever you change the scene ?
I know this is a workaround but both the scene editor and automation editors are currently works in progress, so this would allow you to keep it working ???

Recent moves seem to be favouring moving to scripts and to be honest that is what I have always used.

Can you advise if the editor changes the scene (ie the file) if you are working on ANY scene (ie not the one you have the RGB controller in) or is only when you work on a particular scene that controls it ?

I don’t know how the scene editor works as I don’t use it myself, I only use scenes to take a snapshot of some entities and restore the snapshot afterwards (as you may have guessed already, I’m using this in AppDaemon :rofl:).
I think the scene editor let’s you choose some entities which you want to have included in the scene and it will then take automagically all the attributes etc. from this entities as they are now, therefore it includes the hs_color, xy_color etc. as well. I still think my way is the easiest option, because most of the time you create scenes once and maybe some adjustments afterwards, but after that you mostly don’t touch the scene anymore, so I think it’s the best to just remove the attributes you don’t want to have included in the scene.
However now that scenes don’t support transition anymore and also some domains not being supported anymore (the remote domain is the best example that forced me to use scripts now, as the remote integration doesn’t support reproduce state, I know it could be fixed in the integration, but why bother when you have scripts), they are useless for most people and most people use scripts now as you suggested.

Ou sorry, I didn’t see your comment. Why do you need to change the scene? Normally when I used scenes, I defined them once and then only touched it again when I added an additonal action.

You could also use the scene editor and still have some manual scenes with scene_old (see the documentation here) then keep this scene in the manual scenes and for the other scenes use the editor.

Those are all nice alternative approaches. Still I was under the assumption that the latest HA releases was building on the scenes integration with the new UI editor, making snapshots using automations/scripts on the fly etc, etc. So here I thought scenes is the future and I need to get on the wagon, guess I was wrong and scripts are the future?

The LED-strip in question is the kitchen bench lightning so It’s pretty involved in every type of scene I can think of. And it would still pose a problem when using snapshots. But I guess I just have to do it the hard manual way and script everything… or buy a new dimmer :wink:

Hi, sorry to bring back an old post. How is your RGBW controller configured to control only the white channel as a switch? What is your parameter 14 set to?

I have the same controller and am struggling to make it work.