Prepping for 0.107.0

Search everywhere doesn"t need to be in groups.yaml.

Sorry, war ein versehen, danke.
But by the way, I do not have such entries neither in groups nor in automation or configuration.yaml.
All what I’ve found is the old default_view in the groups yaml.
I already deleted these entries and will see if the warning during start up still appears.

that’s what i was hoping the warnings would point to where the issue was as my install is massive.

however, i did just stumble upon it.

the issue was in the only package i could think possibly had a group. it was the battery-alert package i use for batteries notifications.

Doesn’t matter how massive your code is. With Visual Studio code for example you can search your entire config in a few seconds.


understood. i’ll look into using something like that for the future. i’ve been just using simple editors over the past few years and haven’t used a full blown IDE with advanced search features yet

ty :+1:

Do it! It’s easy and there’s also an extension for visual studio code to connect to home assistant. This way it will auto-populate entities you have in your system and some other nice features.
If you use Home Assistant (formerly there’s also an add-on to have Visual Studio Code in the browser.

1 Like

Not if you’re on a pi (won’t run on arm) but you can install it on a third party workstation

Visual Studio Code does now work on RPi.

1 Like

Only on 64bit OS

I’m on Ubuntu with docker(recently migrated to hassio for easier add-on usage).

I try to do my research before asking but this was bugging the hell out of me. :slight_smile:

@sparkydave, @a_lunatic, Well … That’s half a step forward.
I run HA on a pi 3 and a pi 4.

The pi 3 runs hassos 32bit (recommended) - I suppose that could be upgraded to hassos 64bit ? Then restore a snapshot.

The pi 4 has an ssd, so runs buster from the sd to load the System from ssd. Buster is (I believe) only currently available in 32 bit form.

Bugger !!! :sob:

Actually, it’s pretty convenient running vsc from a workstation as its one instance for both pi’s (test and production) and Im not tempted to run it over a phone or tablet. Cutting and pasting is a nightmare.

I have a similar problem, but with a warning about hide_if_away.

I use VSC and have done a search but no results found.

Any ideas where it might be hiding ?


Same here!

Cannot find hide_if_away anywhere.

Can you show the warning please?

I also got the message about hide_if_away and finally found it in known_devices.yaml. I also use VSCode and the search function did not find it.

Then you need to adjust how you search for it. I just tested it on my machine and it found it after a few seconds in known_devices.yaml.
When you click on the three dots next to the search field press on the small cog wheel next to “files to exclude”

1 Like

Did that, removed all the excludes to check.
I did find some in known_devices.yaml a while ago and deleted those then, still get the warning in the log no though. I’ve deleted it now, I’ll paste it when it pops up again

Sorry to hijack, quick question about VSC. Anyone know what checkbox / option to de-select to have it STOP SHOWING this stupid suggestions lightbox/popup?


I went into settings to try to find it, but there are literally 40 different options, thought asking might be faster. Thank you!

Hi I have the same issue. This shows up for me anytime I run a “Check Config”:
The 'hide_if_away' option (with value 'False') is deprecated, please remove it from your configuration. This option will become invalid in version 0.107.0

Yes, same message here, when I do config check

The ‘hide_if_away’ option (with value ‘False’) is deprecated, please remove it from your configuration. This option will become invalid in version 0.107.0
7:26 PM helpers/ (WARNING) - message first occurred at 7:26 PM and shows up 3 times