Printing with CUPS

I run it on a different pi than hass. But is more economical to put them both on the same pi.

Well there is a question with a lot of fish hooks!

Easy answer, it is all open source so either trust that any errors are obvious or see for yourself :slight_smile:

Not so easy answer - this addon depends on a large train of trust, you need to trust the following:

  • Debian (extremely safe, there are a lot of eyes on debian)

  • The HA debian addon images (I don’t know what they do to them, but probably very safe, the devs here know their stuff and many official and community addons are built on those images).

  • On top of the base images there are a number of packages installed from debian repos, again all probably extremely safe.

  • Then we have the authors work on top of that. It is easy to see on his github. Nothing leaps out as bad, but without knowing all the possible things that could go wrong, who knows? Looks pretty innocuous though.

Frankly it looks as trustworthy as any other addon, but no guarantees about anything!

2 Likes

Sound answer, thanks!

Ive installed the addon. I can print a test page.
Airprint doesn’t work though, any ideas?

I don’t have any iDevices, but there is a nice howto here CUPS and Raspberry Pi AirPrinting | Developer.com

I installed the ncarr addon, it works printing a test page from cups interface. But not airprint. Has anyone succeeded airprinting through the ncarr addon?

Repeating yourself is pointless. Did you look at that howto?

Hi nickout, thanks for trying to help.
I reckoned my question wasnt complete, hence I added mentioning the name of the addon from which to operate.
I read it, and all that seems relevant (share, share internet) is already configured. Kerberos and such disabled.
Has anyone got airprint working with the addon?



The addon seems to work pretty well but I wanted to get SMB as well. I tried forking the project and adding SMB but it did not work. If anyone has any tips for me I would appreciate it. Here is a link to my fork: https://github.com/Luk164/addon-repository

@rieschard Did you managed to have it working, including Airprint?

Hi there,

I was able to install the CUPS add-on based in image ydkn/cups for arm32v7 (RaspberryPi 2). It worked fine, but when I’m trying to add a new printer, the admin access is restricted to the IP 172.30.33.1. Any new configuration used in cupsd.conf, in a personal fork from GitHub - ncarr/addon-repository: Nicholas' Home Assistant addon repository, is completely ignored (I have a previous working configuration for my local network).

I don’t know that IP, I suspect it came from the original image and I’m not getting how to change or ignore it.
Is there any hint?

New add-on by @MaxW

Is any better than GitHub - ncarr/addon-repository: Nicholas' Home Assistant addon repository?

This addon works great!

Can you please mark it as solution so new users do not need to read the whole tread

3 Likes

Hello!
can you help me with the settings?

I’m trying to use the CUPS-PDF virtual PDF printer within this add-on. No problem setting it up, and I can print to it from (say) my iPhone. Problem is, the PDF files are created inside the cupsik container, where I can’t access them except via Portainer.

Has anyone else encountered this scenario and found a solution?

(For background, I’m trying to print to an IPP printer that requires a very specific type of raster image, so I need to be able to detect a new PDF in /var/spool within the container, and CONVERT it and IPPTOOL it to the printer.)

there is any Instructionson how to intall this integration, on the integration page it say " You will need to install the python3-dev or python3-devel package" but how do i install it ? i’m new to ha, i run it on VM in windows, can someone can help and tell me how can i install this?

Which Integration are you referring to?

If you are talking about this addon GitHub - zajac-grzegorz/homeassistant-addon-cups-airprint: CUPS addon with working Avahi in reflector mode then the instructions are right there in the link.

i did not know about this add-on. this was easy thanks, i was talking about this inegration

i add the printer to cups and add ipp to home assistant, can i see if the printer is off ? now when its off i can see the state still Idle

Sorry I don’t know the answer to that.