Problem adding Aqara gateway

Tags: #<Tag:0x00007f7397d3c130>

I am trying to add my aqara gateway to my Home Assistant configuration but I am constantly receiving an error message. Unfortunately I have not been able to identify my key, but as I understand this should be optional in the configuration and from the error messages it does not look like this is the problem either….

This is what I have currently added to my configuration.yaml (MAC address hashed)

xiaomi_aqara:
  gateways:
    - mac: ############

and below are the entries I can see in the log when restarting my device. Does anyone have any suggestions what I should try next?

Setup failed for xiaomi_aqara: Integration failed to initialize.
9:04:56 PM – setup.py (ERROR)

No gateway discovered
9:04:56 PM – xiaomi_aqara (ERROR)

Setup of xiaomi_aqara is taking over 10 seconds.
9:04:51 PM – __main__.py (WARNING)

Key is not provided for gateway ############. Controlling the gateway will not be possible
9:04:41 PM – xiaomi_aqara (WARNING)

Look at the error. It tells you the problem. You need to provide a key, not a MAC address. See the documents on how to set it up:

For one gateway to avoid errors, don’t provide the MAC address.

Hello Tom and thank you for your answer!

According to the documentation you are linking to (and I also have read up and down many times already :grinning: ), the key should actually be ‘optional’. Secondly when I look at the error messages from the log, it says that as the key is not provided I will not be able to ‘control the gateway’ - which is fine as I for now am only looking at reading data.

In regards to the MAC address I have tried both with and without, as well as all other tweaks and combinations I can think of…

It can very well be that you are correct and the ‘key’ is actually mandatory, contrary to what the documentation says. However as I am struggling to find this ‘key’ through the methods described online, I just wanted to check here if anyone else have managed to get this to work without having the ‘key’.

For one gateway don’t supply a mac:

As mentioned I have tried both with and without the MAC address, without any success. Anyway I will continue to dig and maybe I will stumble across a working solution.
Anyway thank you for trying to help!

Did you go through the troubleshooting steps at the bottom of the document?

Without the key you wont get anywhere. the key part is not optional