Problem configuring assistant relay

I think I’ve read every thread here and have done all the troubleshooting I can think of, and so begrudgingly post here asking for help again.

I’ve got Assistant Relay setup and working in sandbox mode on port 3000 - It’s all great. Does what I need it to do. The integration into HA is what is broken.

I’ve tried to issue commands from an automation and from a button card in Lovelace with no success.

Here’s the relevant code from configuration.yaml

    url: 'http://homeassistant.local:3000/assistant/'
    method: 'post'
    content_type: 'application/json'
    payload: '{"user": "Home","command": "{{ message }}"}'

And here’s the automations.yaml

- id: '1634753047489'
  alias: Test Lights
  description: ''
  - platform: time
    at: 05:45:00
  condition: []
  - service: rest_command.assistant_relay
      message: turn off the living room light
  mode: single
  max: 10

Any help is appreciated.

Are you really using homeassistant.local as the URL? If so, use the IP address instead.

I’ve tried it both ways. It’s currently setup as pasted in the previous code, but didn’t work with the IP address either.

I just deleted the whole thing - project in the developer console and the add-on. Reinstalled/setup everything and now it works. I can’t imagine what went wrong, but it’s working now.

Was it possibly related to that thing the crops up from time to time, that because the project isn’t actually published, Google periodically disable it?

Could be. Or I could have just screwed something up along the way.