Problem configuring Lutron RA2

I’m new to Home Assistant. I got it up and running generally, but I am having a problem with Lutron.

I had an installer setup my lights, shades, etc., with a Lutron RA2 and a Lutron Connect Bridge. I have about a dozen lights and 5 shades. I am using HA v 2022.11.3.

Home Assistant sees the Lutron Connect Bridge, and lists 1 device and 1 entity – namely, the Bridge. It does not see or otherwise set up any other Lutron stuff. (I did read the documentation, and I realize it is supposed to set up the switches as events rather than devices, but I’m getting nothing.)

I went through the configure process, and I put in the xxx-xx-xxx code from my Bridge to get it paired. But I am getting an error saying that it couldn’t start Lutron. I also went into the configuration.yaml and added the following:

Lutron configuration

username: [my e-mail]
password: [my password]

I suspect I’m doing something wrong in this configuration. First, for the host, am I supposed to use the Bridge’s IP address or the RA2’s IP address? When I try the Bridge’s IP address, I get a configuration error, but if I use the RA2, I get an uncaught exception error. In both cases, Lutron doesn’t seem to be loading up in HA.

I also note that the config file is supposed to have a Username, but my installer set up my system with the username blank,although there is an e-mail address and a password. If I go into a web browser and type in the RA2’s IP address, the Login page accepts my e-mail address as the user name. So, I have tried the configuration.yaml file with the user name blank and with my e-mail address, and neither are working.

Here is the error log I get when I use the e-mail address as the user name and the RA2 IP address as the host, let me know if I should post the errors for any other combination:

# Lutron configuration
2022-11-17 05:44:12.308 ERROR (Thread-2) [pylutron] Uncaught exception

Traceback (most recent call last):

File "/usr/local/lib/python3.10/site-packages/pylutron/", line 171, in _main_loop


File "/usr/local/lib/python3.10/site-packages/pylutron/", line 158, in _maybe_reconnect


File "/usr/local/lib/python3.10/site-packages/pylutron/", line 133, in _do_login_locked

self._telnet.read_until(LutronConnection.PROMPT, timeout=3)

File "/usr/local/lib/python3.10/", line 329, in read_until

return self.read_very_lazy()

File "/usr/local/lib/python3.10/", line 405, in read_very_lazy

raise EOFError('telnet connection closed')

EOFError: telnet connection closed


All, I got mine working. For others with similar problems, the issue was that my installer used his username and password for Telnet, and he had not set up a Telnet username and password for me. So, mine worked within the Lutron app, but did not work for Telnet purposes. He came by this morning and set up a Telnet username and password for me, and now everything works.