Problem Connecting ESP32S

Hey All,
I’m new to this platform, but have worked using Arduino before, I have a plant growing project using sensors and I’m trying to connect a few sensors to my ESP32 and send data over the web.
I have done this using the Arduino platform but I need something more robust for building the firmware and this is how I got here.

So to my problem, I have downloaded the Home Assitant and ESPHome add-on, and loaded the basic OTA firmware unto my ESP32S with a static IP of, after flashing using the ESPHome Flasher I receive this message:

Using 'COM8' as serial port.
Detecting chip type... ESP32

Chip Info:
 - Chip Family: ESP32
 - Chip Model: ESP32D0WDQ6 (revision 1)
 - Number of Cores: 2
 - Max CPU Frequency: 240MHz
 - Has Bluetooth: YES
 - Has Embedded Flash: NO
 - Has Factory-Calibrated ADC: YES
 - MAC Address: 9C:9C:1F:C2:AE:D0
Uploading stub...
Running stub...
Stub running...
 - Flash Size: 4MB
Erasing flash (this may take a while)...
Chip erase completed successfully in 1.2s
Compressed 15680 bytes to 10109...
Wrote 15680 bytes (10109 compressed) at 0x00001000 in 1.0 seconds (effective 129.1 kbit/s)...
Hash of data verified.
Compressed 3072 bytes to 143...
Wrote 3072 bytes (143 compressed) at 0x00008000 in 0.1 seconds (effective 337.0 kbit/s)...
Hash of data verified.
Compressed 8192 bytes to 47...
Wrote 8192 bytes (47 compressed) at 0x0000e000 in 0.1 seconds (effective 1022.3 kbit/s)...
Hash of data verified.
Compressed 872048 bytes to 486767...
Wrote 872048 bytes (486767 compressed) at 0x00010000 in 45.3 seconds (effective 153.9 kbit/s)...
Hash of data verified.

Hard Resetting...
Done! Flashing is complete!

Showing logs:
[21:16:35]ets Jun  8 2016 00:22:57
[21:16:35]rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
[21:16:35]flash read err, 1000
[21:16:35]ets_main.c 371 
[21:16:35]ets Jun  8 2016 00:22:57
[21:16:35]rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
[21:16:35]configsip: 0, SPIWP:0xee
[21:16:35]mode:DIO, clock div:2
[21:16:35]ho 0 tail 12 room 4
[21:16:35]entry 0x400806e8
[21:16:35][I][logger:166]: Log initialized
[21:16:35][C][ota:366]: There have been 0 suspected unsuccessful boot attempts.
[21:16:35][I][app:029]: Running through setup()...
[21:16:35][C][wifi:033]: Setting up WiFi...
[21:16:36][D][wifi:324]: Starting scan...
[21:16:37][D][wifi:339]: Found networks:
[21:16:37][I][wifi:385]: - 'Saadon 1' (88:C3:97:83:3D:0D) ▂▄▆█
[21:16:37][D][wifi:386]:     Channel: 6
[21:16:37][D][wifi:387]:     RSSI: -67 dB
[21:16:37][I][wifi:385]: - 'Saadon 1' (10:13:31:77:49:6F) ▂▄▆█
[21:16:37][D][wifi:386]:     Channel: 1
[21:16:37][D][wifi:387]:     RSSI: -89 dB
[21:16:37][I][wifi:194]: WiFi Connecting to 'Saadon 1'...
[21:16:38][I][wifi:457]: WiFi Connected!
[21:16:38][C][wifi:303]:   SSID: 'Saadon 1'
[21:16:38][C][wifi:304]:   IP Address:
[21:16:38][C][wifi:306]:   BSSID: 88:C3:97:83:3D:0D
[21:16:38][C][wifi:307]:   Hostname: 'test'
[21:16:38][C][wifi:311]:   Signal strength: -69 dB ▂▄▆█
[21:16:38][C][wifi:315]:   Channel: 6
[21:16:38][C][wifi:316]:   Subnet:
[21:16:38][C][wifi:317]:   Gateway:
[21:16:38][C][wifi:318]:   DNS1:
[21:16:38][C][wifi:319]:   DNS2:
[21:16:38][D][wifi:466]: Disabling AP...
[21:16:38][C][ota:029]: Over-The-Air Updates:
[21:16:38][C][ota:030]:   Address:
[21:16:38][C][api:022]: Setting up Home Assistant API server...
[21:16:38][I][app:059]: setup() finished successfully!
[21:16:38][I][app:105]: ESPHome version 1.16.2 compiled on May  3 2021, 18:14:29
[21:16:38][C][wifi:443]: WiFi:
[21:16:38][C][wifi:303]:   SSID: 'Saadon 1'
[21:16:38][C][wifi:304]:   IP Address:
[21:16:38][C][wifi:306]:   BSSID: 88:C3:97:83:3D:0D
[21:16:38][C][wifi:307]:   Hostname: 'test'
[21:16:38][C][wifi:311]:   Signal strength: -66 dB ▂▄▆█
[21:16:38][C][wifi:315]:   Channel: 6
[21:16:38][C][wifi:316]:   Subnet:
[21:16:38][C][wifi:317]:   Gateway:
[21:16:38][C][wifi:318]:   DNS1:
[21:16:38][C][wifi:319]:   DNS2:
[21:16:38][C][logger:185]: Logger:
[21:16:38][C][logger:186]:   Level: DEBUG
[21:16:38][C][logger:187]:   Log Baud Rate: 115200
[21:16:38][C][logger:188]:   Hardware UART: UART0
[21:16:38][C][captive_portal:169]: Captive Portal:
[21:16:38][C][ota:029]: Over-The-Air Updates:
[21:16:38][C][ota:030]:   Address:
[21:16:38][C][api:095]: API Server:
[21:16:38][C][api:096]:   Address:

From what I understand this means that everything went well and the ESP managed to connect to WiFI, after the flashing I get a notification from Home Assitant that I have a discovered new node, I press to connect to it and then I get an error message saying this:

Can anyone please help me? I tried changing the dns, IP and several other things but nothing works, I would appreciate any advice.


Have this in your yaml and reflash it (can be done OTA).

I already do have, I tried both with password and without:

  name: test
  platform: ESP32
  board: nodemcu-32s

  ssid: "Saadon 1"
  password: "0547258525"
  # Optional manual IP

  # Enable fallback hotspot (captive portal) in case wifi connection fails
    ssid: "Test Fallback Hotspot"
    password: "BptzOaToGdag"


# Enable logging

# Enable Home Assistant API


Also I cant connect to the OTA, log or anything else, nothing that requires connecting to the device using the Hassio works.

This is what I get when I try to use the OTA, for example.

What is the ip adress and subnet mask of you home assistant?

Go into the .storage folder on home assistant. There should be a copy of the nodes config file, it won’t be the same name. You’ll have to open the files and read the contents to find a match. If it exists delete it.

Also if you have loaded other sketches to this node, during testing etc, check for a copy of that config and delete.

If you define a static ip address in the yaml and it’s already assigned to another device in your network. Then you get something similar that you experience.


First, I swore off static IP addresses about a year ago and very happy with that decision. I have over 65 IP devices on my network and managing the static IP addresses was becoming tedious. Now, I just set the DHCP lease in my router to ‘permanent’. It has the same effect as static IP but so much easier to manage.

I suspect that your problem is that the router has no history of this device yet and is assigning an address from DHCP.

Try removing the manual_ip: lines. (Comment them).
If this works, and upload succeeds, then I am right.

Hey all, so removing the static IP did not help, had the same issue, however seems like the problem was indeed related to the IP and router, my router uses a different IP address prefix, meaning 192.168.1. and not 10.0.0, once I used as fixed address that worked out.

Thanks for the help!

So thus related to my question. Glad its solved.