Problem connecting/mounting SSD via USB to


I’m having troubles connecting an external SSD drive via USB3 to my Raspberry Pi 4 Running on HassOS.

The SSD is a Kingston 440 GB drive, NTFS formatted, connected via a Deltaco USB kabinett. It runs fine on Windows 10.

Searching this (and other) forums, I expected the drive to be visable in hassio when under system/hardware (or hassio hardware info in the terminal), but there is no e.g. /dev/sda entry there.

However when I run dmesg in terminal i see that the system identifies the disk (i.e. not completely dead) but also somehow seems to fail to connect (?)

[130772.029220] usb 2-1: new SuperSpeed Gen 1 USB device number 3 using xhci_hcd
[130772.059954] usb 2-1: New USB device found, idVendor=174c, idProduct=55aa, bcdDevice= 1.00
[130772.059976] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[130772.059989] usb 2-1: Product: USB3.0 External HDD
[130772.059999] usb 2-1: Manufacturer: ASMedia
[130772.060009] usb 2-1: SerialNumber: 201701000040
[130772.069612] scsi host0: uas
[130772.070793] scsi 0:0:0:0: Direct-Access KINGSTON SA400S37480G 0 PQ: 0 ANSI: 6
[130772.072014] sd 0:0:0:0: [sda] 937703088 512-byte logical blocks: (480 GB/447 GiB)
[130772.072146] sd 0:0:0:0: [sda] Write Protect is off
[130772.072162] sd 0:0:0:0: [sda] Mode Sense: 43 00 00 00
[130772.072372] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
[130772.072945] sd 0:0:0:0: [sda] Optimal transfer size 33553920 bytes
[130772.078728] sda: sda1
[130772.080517] sd 0:0:0:0: [sda] Attached SCSI disk
[130772.093308] udevd[576]: inotify_add_watch(6, /dev/sda, 10) failed: No such file or directory
[130772.095932] udevd[576]: inotify_add_watch(6, /dev/sda1, 10) failed: No such file or directory
[130772.097765] udevd[77]: inotify_add_watch(6, /dev/sda, 10) failed: No such file or directory
[130772.100015] udevd[77]: inotify_add_watch(6, /dev/sda1, 10) failed: No such file or directory

I have also tried using different USB-ports as well as formatting the SSD as Ext4, but no luck.

One major purpose with the home assistant for me is to set up a home surveillance system and run MotionEye as an addon. Therefore I would like to store any recordings on an external drive, hence the SSD.

Also, one purpose would be to move the hassio database to the SSD to minimize writings to the SD-card, but I figure I need the SSD to be mounted first :slight_smile:

Could anyone explain what I’m doing wrong? Or how to figure out what the problem is so I can correct it?

I’ve just started my home automation journey and I’m not very familiar with RPi’s, Linux, Docker, HA etc. so any help is much appreciated!


One thing you can do is to install raspbian, and then install hassio following the instructions here :

Thank you @francisp, I have considered that. Before doing that I would like to understand if the problem is with the OS and not with i.e. the hardware etc.
Are you saying that HassOS does not support adding of additional SSD drives, or simply that by running of a more generic distribution, I have more options for solving the issue?

Both. Hassos is a minimal distribution focused on running Hassio.

I actually ended up following the excellent guide in this post, which worked splendidly. Thanks @skynet01!

hi, i have exact same problem here unfortunately. I want to add an USB Drive for moving log files. But if i understant it correctly, you reinstalled HA completely the like skynet01 described?

Mayby its better to move booting of rpi complete to the USB disk, and instead of the SD.

From what I have read booting from USB is not yet supported on RPi4 yet. It should work on RPi3 though.

In the guide I used I think they actually restored the complete HA using a snapshot after the migration to USB disk, but I didn’t try that myself.

I just followed the guide, and it works.

The SD card is only used for only booting, everything else (All other files) are located on the USB drive. So all logs etc from HA are also on USB instead of SD Card.

Installed raspbian
Moved everything to USB with use of the guide
Installed HA

Works fine! :slight_smile:

1 Like