Problem getting Duckdns working with Asus router

I´m new to home assistant and want to get started with duckdns.
I have looked on a video how to configure it, and thought it should work, but still I get a error when I try to use my duckdns domain.

So I have set up DuckDNS addon with no errors:
{
“lets_encrypt”: {
“accept_terms”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
},
“token”: “mytoken”,
“domains”: [
mydomain.duckdns.org
],
“seconds”: 300
}
The configuration.yaml file looks like:
http:
api_password: myapi_password
base_url: https://mydomain.duckdns.org:8123
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

and restarts with no errors

On my Asus router I have added a port forwarding from 443 to 8123 for my internal IP for the home assistant:

Router is restarted!

When trying to enter the address in a webbrowser (also tried in Incgnito mode) I get the following error:
ERR_SSL_PROTOCOL_ERROR
The webpage could not enable a safe connection:

What have I missed?

Can you translate the dialog box please?

When I run Edge (where I get English error messages) I get this error:


I.e. I assume there is a problem on the router or similar.
Are there any way to verify that the router settings is correct?

When I used telnet on my local machine, I got this error, might indicate that the router setup is not proper?

Connecting To https://mydomain.duckdns.org...Could not open connection to the host, on port [443]: Connect failed

Are you trying to connect from within your own lan?

I have tried both from within the network as well as from outside, but get the same error!

In your configuration.yaml under base url try taking off the “https://” so it matches what you have in the DuckDNS config.

Configure your TCP/IP Port number separately:

http:
  base_url: https://mysite.duckdns.org
  server_port: 8123
  ssl_certificate: /ssl/certfile.pem
  ssl_key: /ssl/privkey.pem

Thanks both of you! I will try both tips when I get back home! Will inform if any of those tips solved my problem!

1 Like

Back home, and I have tried to get it up and running, but with no success! :frowning:

I suspect some settings on my router needs to be updated, but I have no clue what to change!
Any ideas what to do to make it work, or anything I can do to try to find the root cause?

You could try to forward port 8123 to port 8123.

The topic ends here? I have the same problem with asus router. Did you manage to solve it?

Hassio sau regular Home Assistant?

Hassio on pi4 accessing via browser with home assistant

If you are having problems with port forwarding on an asus router ASK ASUS. This is not the asus forum.