Problem instaling hassio supervised on Ubuntu & Intel NUC

I am getting a problem with a re-installation on docker (ubuntu server).
I am following this guide
Installing Home Assistant Supervised on Ubuntu 18.04.4

In the commande:

curl -sL “” | bash -s
I get “invalid reference format”

I have the feeling that this command in the script i failing:


Printing the variable above I see that the $HASSIO_VERSION is empty and the command seems to be

docker pull homeassistant/amd64-hassio-supervisor:

changing to

docker pull homeassistant/amd64-hassio-supervisor:latest

(that works from the command line) gives men this when running the script above with Curl:

Error response from daemon: Get dial tcp: lookup on dial udp connect: network is unreachable

I am on Ubuntu.
Any suggestions?
My HA is completley down so I am in big rouble…

Why not ask directly in the topic you got the guide from?

1 Like

If you have Intel-NUC, install ‘proxmox’ 1st, then you have many other possibilities…
This is what I would suggest.

1 Like

If you are starting fresh on a NUC, don’t use Ubuntu, there is no reason to use it. Follow one of these instead, and read the instructions.


Hello and thanks,
I was running Ubunto and had my HA up running with some configuration.
For some reason I installed a old snapshot and after this is completely failed so I decided to re-install HA on my docker and this is where it failed.
I like to have a supervised version and I hope I can re-install my latest snapshot.

If I install on Debian, will I be able to recreate my old snap from Ubuntu?
Same question goes to this Proxmox? - this Proxmox is new to me…
Thanks for all responses!

Yes, any version that uses the Supervisor will restore a snapshot.

I am now backing up my stuff on the soon-to-be-gone Ubuntu…
Should I go the Debian directly or Proxmox path?
Never heard of proxmox hence the question…

Proxmox let’s you run virtual machines, this way you can run multiple systems for different things, like for example a media server in a virtual machine and Home Assistant in a virtual machine. It all depends on your needs.

I am now up running a new HA on proxmox and it worked great.
Now I am trying to upload the snapshot to this new HA and figured I use Samba.
However I cannot see the HA samba server on my network, are there some additional config for Proxmox I need to take care of?
Did google but no obvious answers…

You should be able to upload a snapshot from the HA web interface.

Go to Supervisor—>Snapshots----->Click the 3 dots in the upper right corner----->Upload Snapshot

thanks - need to check my eyes…

All good, it’s only a new feature that many people aren’t aware off.

Hi may I ask something because I am a little confused. Right now HA is installed in a NUC with ubuntu supervised or whatever the name is.

I use the nuc ubuntu to stream netflix and stremio or listen music browse etc in my TV .
Can I do that with proxmox? I mean can I have HA in virtual machine and isntall ubuntu in another to use it with my TV or I should move to debian? (I assume I can use debian as ubuntu for my TV)

I am new to proxmox and installed in just the other day.
It worked perfect to set up HA and now a supported version :slight_smile:
I also created another VM and installed Ubuntu for the stuff I need that to.
I would say it’s a great combination!
I chose two VM’s but perhaps another container would be better… not sure… just try it!

1 Like

If someone ends up here in 2021 or later, the reason is simple. The script tries to reach docker registry while the NetworkManager is still restarting. To continue your installation comment out the line where the NetworkManager is being restarted systemctl restart "${SERVICE_NM}" and rerun the script. Or you can add some sleep command before.