Problem installing on VirtualBox on macOS

Hi, I’m new to Home Assistant and I’m excited to get it working, however unfortunately so far the installation process doesn’t live up to its hype :frowning_face:

I have previously tried running HA Core via docker-compose on macOS (Mac Mini) and I was able to start it up almost effortlessly, however for certain reasons (which I will list below for convenience) I’ve decided to try to run hassio in VirtualBox on my macOS.

I’ve tried installing it to the letter as specified in this guide:
The issues that I’m facing are:

  • first of all, (VM’s address from HA CLI’s network info):8123 is returning “connection refused”, while pinging the VM’s IP works just fine, also tried via curl (address):8123 from host - same result
  • sometimes when I start the VM the HA CLI doesn’t start, giving me “[WARN] Home Assistant CLI is not running! …” message after logging in as root - one time this went away after the reboot, but most of the time it stays like this on consequent reboots

What I’ve tried:

  • made sure that network adapter is in bridge mode and pinging to VM’s IP works from the host
  • tried switching “Promiscuous mode” in network adapter settings to “Allow all” as suggested somewhere - to no avail
  • removed the VM, restarted from scratch with the downloaded VDI - got different results on several attempts, sometimes HA CLI boots as expected, but still IP:8123 returns “connection refused”, sometimes HA CLI won’t ever boot, which is super weird, since I would expect the behaviour to be reproducible, since I’m always starting with the exact same VDI

Does anyone have any clue on how to get this running or what I could troubleshoot further? I tried looking up “[WARN] Home Assistant CLI is not running! …” message and found only one discussion about it on this forum, which had some very different context and solution.

Now, why did I stop using Docker image? Two reasons:

  1. I wanted to get started with my Yeelight bulbs, but I couldn’t make them work for the love of my life - I’ve tried discovery, as well as hard-coding all IP addresses in configuration.yaml, I pinged them every time, so the addresses were correct for sure, I’ve also set up LAN control for all of them (and tried re-enabling it just in case) - all of that didn’t work, I could see bulbs as entries, but not entities or devices, what’s crazy is that there were two times when HA somehow discovered one of the three bulbs for a few moments, and I could toggle it from the default dashboard, and after restarting Docker it was gone again :frowning: I have read about some issues with earlier versions of HA related to Yeelight, tried downgrading to earlier Docker image - same issue. I have read about some Yeelight 2.x firmware issues and haven’t found any conclusive solution, so I just gave up on them. I also read about some issues due to some changes in DHCP discovery or smth, so I thought that maybe running hassio from a VM could have a different network setup and work somehow, because honestly - it’s extremely disappointing when you’re just getting started and can’t even get your bulb to turn on from the dashboard :frowning: I’m a software developer with some Docker and Linux experience, but even that didn’t give me enough patience not to get massively discouraged.
  2. I wanted to set up SSL, but since HA in Docker doesn’t come with addons I would have to figure certificate generation locally on my host. After some reading all materials were hinting on setting up a crontab job which would update some certificate stuff, and I thought that it would be a bit too much, since I didn’t want to pollute my host with such stuff, and why go through all this if I can try the supervised version with relatively small effort (or so I thought based on 2 minute docker-compose setup experience) and have addons working out of the box, looking at all those straightforward DuckDNS tutorials.

My original plan was to try out Home Assistant on my macOS, to check out the automation capabilities and the ecosystem in general, so that I could decide if it’s worth buying a RPi to run it there separately. Currently I have a couple of devices and a SmartThings Hub, since some of them are Zigbee only, so I was hoping I could use ST Hub simply as a Zigbee hub via ST/HA integration, while all the automations could live in Home Assistant. Living in Estonia, I don’t have access to vast American market of smart home devices, so mixing and matching is sort of a must, meaning Zigbee/Z-wave hub is also a must, that’s why I went for ST Hub originally. Now I’m seeing that automations on SmartThings are rather limiting, and WebCore is just a band-aid (which also takes some getting used to) with Rules API being in the raw state, so I’d rather look for a better long-term solution early on. So far haven’t managed to solve anything :sweat_smile: Really hope that it will just start working magically one day.

So, I pulled the plug and decided to go “the easy way” and got myself a Raspberry Pi :slight_smile: This time everything is working flawlessly, and it’s so much more convenient having supervisor install all those add-ons on its own, and also knowing that it won’t pollute my actual workspace by doing so (comparing to running it in Docker on the PC).

The issue with Yeelight is still there - I thought of trying to upgrade the firmware by changing the region to China and trying to pair all the bulbs from scratch, but instead I just installed a fork called yeelight_v2 and it has been working flawlessly :sparkles: Maybe it should get merged to the original repo :thinking:

As for virtualbox image – I guess I’ll never know what was the issue, but it doesn’t matter anymore.