Problem installing to x86 (autoboot)

I have installed home assistant several time to Raspberry Pi, manually and using (or Home Assistant Operating System). Now I’m trying to install to x86 platform with no results.

I used Balena Etcher to burn the following image to an hard disk and (when this didn’t work) to an SD card.

The target platform is an Atomic Pi, but after much frustration, not getting it to boot from the hard disk or the microSD on 2 different Atomic Pis, I tried booting the same hard disk from my regular desktop and got the same results.

Invariably, the computers boots to a white screen rectangle (that doesn’t cover the whole monitor) with black characters that says Autoboot in the top left. Every few minutes it reboots to the same Autoboot screen. But sometimes it reboots to another screen that says Shell. The computers never become visible to the network (they are connected via ethernet).

Is UEFI boot mode enabled in BIOS?

I searched tried to enabling it, but after not finding any mention of it, I found that this board doesn’t support legacy BIOS (MBR) booting (reference).

At one of those many reboots it displayed something starting with HAOS. I think that it was HAOS-BOOT:/ and several garbage characters, until it did another reboot. It remained black for about 5 minutes, and then returned to Autoboot again.

If HA OS does not work, you can always try a supervised install on Debian.

Thanks. I’ll have to do that.