Problem installing zwave in 0.45.1

I have a fresh Hassbian installation and tried to enable zwave (I have a razberry GPIO-card).
When i Start Home assistant I got this in my log-file:

2017-05-25 10:31:38 WARNING (Dummy-25) [openzwave] Z-Wave Notification DriverFailed : {‘homeId’: 0, ‘nodeId’: 255, ‘notificationType’: ‘DriverFailed’}
2017-05-25 10:32:08 WARNING (Thread-9) [homeassistant.components.zwave] zwave not ready after 30 seconds, continuing anyway
2017-05-25 10:32:12 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting
2017-05-25 10:34:32 ERROR (Thread-11) [homeassistant.core] Error doing job: Future exception was never retrieved
Traceback (most recent call last):
File “/usr/lib/python3.4/concurrent/futures/”, line 54, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/zwave/”, line 530, in start_zwave
network.set_poll_interval(polling_interval, False)
File “/home/homeassistant/.homeassistant/deps/openzwave/”, line 892, in set_poll_interval
self.manager.setPollInterval(milliseconds, bIntervalBetweenPolls)
File “/home/homeassistant/.homeassistant/deps/openzwave/”, line 562, in manager
raise ZWaveException(u"Manager not initialised")
openzwave.object.ZWaveException: ‘Zwave Generic Exception : Manager not initialised’

I can’t figure out what I’m doing wrong here.

Thanks for any help!


I solved the problem. I needed to disable blutooth on my Pi3

I’m having the same problem, but I am not sure how to disable bluetooth on my Pi3.
I’ve tried to edit /boot/config.txt adding:

My configuration.yaml config looks like this:
usb_path: /dev/ttyAMA0
config_path: /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/libopenzwave-0.3.3-py3.4-linux-armv7l.egg/config

Any help would be appresiated!
// Svein Erik

I followed this guide:

My problem was unfortunately not solved bye following the guide, but thank you for helping :slight_smile:

What solved my problem was following these steps:
1: Install z-way, with following command: wget -q -O - | sudo bash
2: Shutdown z-way-server and disabling autostart with sudo update-rc.d z-way-server remove
3: Reboot with sudo reboot.

Changing ttyAMA0 to ttyS0 and everything is working fine.

// Svein Erik

Edit: Or maybe not…I have to consider starting from a fresh new AIO installation…puhhh :confused: