Home Assistant Community

Problem of upgrading homeassistant from 0.91.4 to 0.92.0

#1

Hi,

problem solved. upgrading python 3.5.3 to 3.7.3

I need help, I can`t upgrade my HA from 0.91.4 to 0.92.0。
Device: Raspberry 3B +
OS: Raspbian
Problem details as follows:

pip3 install --upgrade homeassistant
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting homeassistant
  Using cached https://files.pythonhosted.org/packages/bb/94/dd2d566a504310e386da1ea9fe29547aab102ec87342411d7c8cf9d619e6/homeassistant-0.92.0-py3-none-any.whl
Requirement already satisfied, skipping upgrade: aiohttp==3.5.4 in /usr/local/lib/python3.5/dist-packages (from homeassistant) (3.5.4)
Collecting cryptography==2.6.1 (from homeassistant)
  Using cached https://files.pythonhosted.org/packages/07/ca/bc827c5e55918ad223d59d299fff92f3563476c3b00d0a9157d9c0217449/cryptography-2.6.1.tar.gz
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
ERROR: Exception:
Traceback (most recent call last):
  File "/usr/local/lib/python3.5/dist-packages/pip/_internal/cli/base_command.py", line 178, in main
    status = self.run(options, args)
  File "/usr/local/lib/python3.5/dist-packages/pip/_internal/commands/install.py", line 352, in run
    resolver.resolve(requirement_set)
  File "/usr/local/lib/python3.5/dist-packages/pip/_internal/resolve.py", line 131, in resolve
    self._resolve_one(requirement_set, req)
  File "/usr/local/lib/python3.5/dist-packages/pip/_internal/resolve.py", line 294, in _resolve_one
    abstract_dist = self._get_abstract_dist_for(req_to_install)
  File "/usr/local/lib/python3.5/dist-packages/pip/_internal/resolve.py", line 242, in _get_abstract_dist_for
    self.require_hashes
  File "/usr/local/lib/python3.5/dist-packages/pip/_internal/operations/prepare.py", line 368, in prepare_linked_requirement
    abstract_dist.prep_for_dist(finder, self.build_isolation)
  File "/usr/local/lib/python3.5/dist-packages/pip/_internal/operations/prepare.py", line 175, in prep_for_dist
    self.install_backend_dependencies(finder=finder)
  File "/usr/local/lib/python3.5/dist-packages/pip/_internal/operations/prepare.py", line 123, in install_backend_dependencies
    reqs = req.pep517_backend.get_requires_for_build_wheel()
  File "/usr/local/lib/python3.5/dist-packages/pip/_vendor/pep517/wrappers.py", line 71, in get_requires_for_build_wheel
    'config_settings': config_settings
  File "/usr/local/lib/python3.5/dist-packages/pip/_vendor/pep517/wrappers.py", line 162, in _call_hook
    raise BackendUnavailable
pip._vendor.pep517.wrappers.BackendUnavailable
#2

Are you using a venv? If so did you ‘activate’ it?

#3

I am not using venv.
when I install cryptography separately, also the same problem.
I can install cryptography 0.25,but I can`t install cryptography2.6.1( HA0.92 needed)

#4

OK, I am and it worked for me using pip. However I don’t know enough about pip to diagnose further. If I find anything I’ll let you know.

#5

I was in venv on raspbian and I’ve got some problems…solved installing some packages before upgrade…

sudo apt-get install build-essential libssl-dev libffi-dev python3-dev

…as described here…

#6

I installed those packages as you said
it also not works

#7

Problem solved. upgrading Python 3.5.3 to 3.7.3。

#8

the Python upgrade solve my problem, thanks

#9

How do I upgrade python to home assistant in docker container?

Thanks,

#10

I have hass 0.91.4 on raspberry Pi 3 and i try to update got error
" Installing build dependencies error" and then a bunch of red text like 2-3 pages.

should i update python to 3.7.3, how do i do it?

#11

From your home folder on your Raspberry Pi type the following

sudo apt-get install libssl-dev

Once complete upgrade as usual. The red stuff you refer to I imagine refers to cryptography issues which the above solved.

This tip compliments to @bosborne which solved my problem.

#12

I tried the install of libssl-dev yesterday and that did not help.

today i rdp to my rpi and try to run the update of home assistant and it gets stuck at

Building wheels for collected packages: cryptography
Building wheel for cryptography (PEP 517) … \

then freezes then i close and open rdp again and the session is lost, not sure if rpi is rebooting.

update: the next rdp session i connected and try run the update again, and it froze at same point but this time i lost rdp and never able to get back. I guess i have to call home to reboot the rpi

#13

Update: After an hour or so i tried connecting to my pi and i see HS got updated.
I have no idea why it froze in first place. hopefully it does not happen again on next update.

#14

During the update it didn’t freeze. It was building PEP 517 cryptography. Takes quite a while but as you see it worked and resolved your issue.