Problem Power consumption recording with IR head Weidmann from Logarex LK13BD

Unfortunately, I have problems finding a suitable integration for HA to read the data from the electricity meter.
Hass OS 5.8 runs on a Raspberry PI 3b with HA 2020.12.7
The electricity meter is a Logarex LK13BD.
As a sensor I use an IR read / write head USB from Weidmann.
I wanted to use EDL21 as an integration. This should actually be compatible with the Weidmann sensor. Unfortunately, that doesn’t work.
The sensor is recognized in the hardware info of HA:

  - /dev/ttyAMA0
  - /dev/ttyACM0
  - >-
  - /dev/ttyUSB0
  - /dev/serial/by-id/usb-FTDI_FT230X_Basic_UART_D309V61T-if00-port0

I have the following configuration in the configuration.yaml:

  - platform: edl21
    name: stromzaehler
    serial_port: /dev/serial/by-id/usb-FTDI_FT230X_Basic_UART_D309V61T-if00-port0

After a reboot, however, no “electricity meter” sensor is registered or displayed in HA.
I also entered a different port:

  - platform: edl21
    name: stromzaehler
    serial_port: /dev/ttyUSB0

Unfortunately without success.

Then I read out the meter data directly with the Weidmann test program. That worked and resulted in the following data sets.

Emlog Testprogramm v.1.08
Test 1 mit Baud 9600 8N1 unidirektional:
Ergebnis: Keine Daten
Test 2 mit Baud 9600 8N1 bidirektional:
Ergebnis: Keine Daten
Test 3 mit Baud 300 7E1 unidirektional:
Ergebnis: Keine Daten
Test 4 mit Baud 300 7E1 bidirektional:
Ergebnis: /?!
0.2.1(ver.02, 130314, 41BD)

Test no. 4 has output the current counter reading under point 1.8.0.
The “OBIS” protocol was specified here.
Bildschirmfoto 2020-12-23 um 11.41.53
I found the following note in the specifications of the EDL21 integration:

The edl21 integration lets you read German EDL21 smart meters using SML from Home Assistant.

Maybe there is a problem with the protocol?
Has anyone ever managed this in this constellation or can they help here?

Problem gefunden ? Solved the problem ?

EDL21 didn’t support D0

Was genau heißt das? Nicht nutzbar wenn man keinen passenden Zähler hat?

Falls das auf D0 bezogen ist… Nicht nutzbar, bis jemand EDL21 oder DSMR anpasst

Hallo, gibt es für das Problem inzwischen eine Lösung?

1 Like

I found this:

Thanks. I saw it as well. The meter is to be requested for sending the data. But I’m quite new and do not know how this should be done.

This picture shows it is technical feasible, since it is no problem using a laptop to read the ISKRA ME162 meter:

See also this log for more people having the same issue: