Problem setting up Netatmo on Hassio


I am new to Hassio/Home-Assistant. I have installed Hassio (latest version) on Ubuntu and I am trying to get it to work with a Netatmo thermostat.

My configuration.yaml has:

  api_key: <redacted>
  secret_key: <redacted>
  username: <redacted>
  password: <redacted>

My home-assistant.log shows:

2018-12-09 19:44:28 ERROR (MainThread) [homeassistant.setup] Error during setup of component netatmo
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/", line 148, in _async_setup_component
    component.setup, hass, processed_config)  # type: ignore
  File "/usr/local/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/", line 53, in setup
    'read_station read_camera access_camera '
  File "/usr/local/lib/python3.6/site-packages/", line 73, in __init__
    self._accessToken = resp['access_token']
TypeError: 'NoneType' object is not subscriptable
2018-12-09 19:44:29 ERROR (MainThread) [homeassistant.components.sensor.yr] Retrying in 17 minutes: Cannot connect to host ssl:None [Try again]
2018-12-09 19:44:32 WARNING (MainThread) [homeassistant.components.http.ban] Login attempt or request with invalid authentication from

Any ideas on how to troubleshoot this?

Thanks in advance,

hi. You need to add in configuration.yaml also:

  - platform: netatmo
    relay: relay
       - thermostat

Thanks, I’ll give that a go.

Thanks, that worked.

I have exactly the same error message as OP, except that:

a) I’m using a “presence” camera and not a thermostat
b) no amount of configuring the camera module makes any difference.

Does anyone have any suggestions regarding tests I can perform to get to the bottom of this?

# hass --version
# python3 --version
Python 3.6.6