Problem setting up Samba

Hi everyone,

I am new to HA and I just setup HA on my Pi 3+ and all went well.

I added the Addon for SSH and used Putty to send Sudo commands (which is not working). I have found online that I had to use "hassio homeassistant " but still not as it should be in the videos I see on youtube.

Then I also tried to start Samba so I could go thru my Network using my PC to edit the configuration.yaml file.

Anytime I hit start on Samba… no go.
I have configurations that I can do… but anytime I change something I get an error message.

Any help would be greatly appreciated.

1 Like

Recent changes to the samba addon now requires a password. Just stick any one you wish in your config and remember it when your windows asks you what it is.

Hi Dixey,

I have tried changing the “null” password in the default settings. As soon as I edit the “null” the text changes to red color and I cannot save my changes…

Any idea why?

1 Like

Hi Again,

I figured it out. I had to put the new password in this format " — " otherwise it would not take it. The original null did not have " ".

Thanks for the help.

1 Like

You mean like it says in the documentation?

Hey! Thanks nickrout for great feedback. This was so helpful.

As I stated I’m a newbie on HA and I figured I could ask a question in which I couldn’t figure out the problem.

I didn’t even know there was a documentation on this that I could read about.

You could share a link to that, it would help me.

Thanks for the time and sorry to have bothered you during the holidays.


1 Like

On the addon page in hassio, there is a link, right at the top of the page.

Hi there,
I am also struggling with this. I am trying to connect to windows 10 so the default workgroup that I created is “Homegroup”.
I created a password as per the instructions at the top of the samba share addon page and entered “wlan0” for network.

Please see below:

  "workgroup": "Homegroup",
  "username": "hassio",
  "password": "my password",
  "interface": "wlan0",
  "allow_hosts": [

Do I have to perform more steps to get windows to connect (ie SLL)?

Advice would be welcomed.


What problems are you having?

Thanks for getting back so soon, I have restarted samba after making the changes then when I look in Windows file explorer I can only see the files on the laptop in the homegroup.
Any idea what I’m missing? (I’ve also turned off password protected sharing in the advanced sharing settings of Windows)


What happens when you put


in windows explorer, where ipaddress is the ip address of your hassio machine.


You sir are a saviour! Homegroup has nothing to do with anything. IP address entered, username, PWD, away we go. Let’s see how much damage I can do the config.yaml now! (Going to copy the original somewhere safe 1st!)

Many thanks

My limited understanding is that homegroup is not strictly speaking smb. It is some other microsoft perversion.

Very wise!

Thanks again for the expert guidance! Next step duckdns, tomorrow the world mwahaha!

My machine is on an Azure AD domain. Once File Explorer asked for credentials, I had to choose more options, and enter WORKGROUP\ha as the user name.

BTW, the documentation doesn’t say anything about quotes around the user name or password: