Problem that devices are not recognized as 'not available'

I have integrated my IKEA lamps via Zigbee2MQTT. In the bathroom and toilet, they need to be operated using the regular light switch (meaning the devices are regularly powered off). I have configured the following:

homeassistant: true
advanced:
availability:
active:
# Time after which an active device will be marked as offline in
# minutes (default = 10 minutes)
timeout: 10
passive:
# Time after which a passive device will be marked as offline in
# minutes (default = 1500 minutes aka 25 hours)
timeout: 1500

"0x5cc7c1fffe4bd4c1":
friendly_name: Lampe-Bad-Spiegel
availability:
timeout: 2

In the Home Assistant dashboard and in the automations, they are still displayed with their last status (light on) for more than 10 minutes after losing power. How can I adjust the settings so that Home Assistant recognizes sooner that the lamps are no longer available?

Thanks!