Problem to find new devices in Fibaro integration (no sync?)

Tags: #<Tag:0x00007f739a3c1b98>

Hi all,
i have a Fibaro HC2 correctly connected with HA. I use devices and plugins (Satel alarms) without problems for a few months.
I happened to make some changes on Fibaro (added devices and changed the name) but no changes are displayed on HA.
There is no possibility of updating the configuration to always have the devices synchronized ??
Synchronization seems to work only once!
have idea?

hi, do you resolve the problem?

1 Like

No…
I try many option but its not possible refresh the device! That’s is incredible!

Hi,

I am facing exactly the same issue. I’m curious… Did you make any particular change on Fibaro or Hassio side, I mean changes on the Fibaro devices and/or Hassio entities?
For instance: hiding devices, disabling devices, renaming entities on Hassio, etc…

I was having some doubts after renaming manually some Fibaro integration entities on Hassio. Does renaming entities after their creation breaks the sync?

So I ended up doing the following without success:

  • remove the Fibaro Integration
  • remove every single Fibaro entity
  • restart Hassio
  • add the Fibaro Integration once again
  • restart Hassio

The same entities show up again (with new auto generated names), but the new devices are still missing…

1 Like

I am comforted not to be alone … :expressionless: :upside_down_face:
No, I have not made any particular changes to the names of the devices on the HA side. I don’t remember at least (I have many devices in HC2).
Integration works perfectly for other things. I also manage the Satel alarm control unit well, always connected as a plugin to Fibaro HC2.
Everything is fine except that. I don’t see the device name changes and the new devices on the HC2 side. The situation of the devices seems “frozen”.
I do not know what to say…

Little update:

So finally after digging into the code, checking Fibaro API JSON responses, etc… I found out that the solution to my problem was very simple :

The user configured in Hassio did not have the permissions to see the new device.

On Fibaro side, I simply went to access permissions and changed the settings accordingly.
After that, simply restarted Hassio and finally the device popped up!

1 Like

I’m happy for you … but this is not my solution.
In my case HA is logged in with an administrator account and has access to all devices.
I tried anyway to make a new user and connect HA with that to HC2 but nothing is solved.
If I query the APIs I get answers from all devices, even new ones. So it’s not an HC2 problem …
I dont have ideas.