Problem using Bluetooth LE Tracker in Docker container

I added the bluetooth_le_tracker to the configuration.yaml as described in https://www.home-assistant.io/integrations/bluetooth_le_tracker#rootless-setup.

device_tracker:
  - platform: bluetooth_tracker
    new_device_defaults:
            track_new_devices: true
  - platform: bluetooth_le_tracker
    new_device_defaults:
            track_new_devices: true

When starting the Docker container I get the following error message.

WARNING (SyncWorker_5) [homeassistant.components.bluetooth_le_tracker.device_tracker] No Bluetooth LE devices to track!
ERROR (MainThread) [homeassistant.components.device_tracker] Error setting up platform legacy

I’m using a Raspberry Pi 4 (Model B Rev1.1) to do this.
I saw a lot of topics regarding this issue, but haven’t solved it for me yet.

Is this a known issue when using the Docker image, or am I doing something wrong?
How can I get Bluetooth LE Tracker to work?

1 Like

I know this post is a little old now, however I am having the exact same problems as you. I had it setup via docker container on previous hardware but cannot get it working again. Did you have any luck and if so how did you solve it?

I’m having the same issue when using docker-compose, although it now says that is legacy.

WARNING (MainThread) [homeassistant.components.bluetooth_le_tracker.device_tracker] No Bluetooth LE devices to track!
ERROR (MainThread) [homeassistant.components.device_tracker] Error setting up platform legacy bluetooth_le_tracker

However, I can start bash on the container, and find devices with hcitool lescan