Problem with adding skill to Google Assistant


I have been trying to link my account to Google Assistant. I can successfully log in and get a “Accounts now linked” message, but when I go back and check on my added devices and services - isn’t on the list, and it’s available from the new skills menu.

  • HomeAssistant is updated to the latest version
  • I tried rebooting all home assistants
  • I tried rebooting my FreeNAS (which runs Hass)
  • Tried adding the account both from iOS and Android with latest Google Home app installed
  • I tried waiting for a couple of days before trying again

Looking forward to your reply.
Thanks for an awesome project!

1 Like

I have the exact same problem.
It worked before but i had done some config so I thought it was on my end.
It seems like it will not keep the link. Does not show up and say how many devices is connected

Anyone from the development team can shad some light on this issue?

No one else is experiencing this issue?

Got the same sort of problem. It worked before but needed a clean install.

It login the home assistant cloud, it also login on the Google Assistant but after authorization it can’t update setting.

If I try another email adres it will login on Google assistant but it will not login on home assistant cloud it gives authorize problems. Even when I delete the cloud did and restart server.


Problem solved for me. The login needs to be exact the same. If you use a capital letter in your email adres in cloud login then this capital letter have to be on the Google assistant plugin login. Easily overlooked

same problem here

I have the same problem. can’t be linked in google home app. Awakatanka mentioned that login needs to be exact the same. My logins are the same and it still doesn’t work.

I’m suffering the same issue as well, doesn’t show in the “linked services” section of the Google home app though the linking process seems to work fine.

any update from devs?

A question, can you add other systems? I’m having real big problems with linking any service to my Google Home right now.

Has this been resolved? I did a fresh install of Hass and ever since then, I’m not able to link then I’m not able to link the skill with Home Assistant Cloud.

When I look at the skill page, it shows as linked. but on the Google Home app, I can’t see it as linked.

I am having the same issue, where I am using Home Assistant Cloud, but I cannot get it linked with my Google Home app. It just keeps saying: “Couldn’t update the settings. Check your connection.”

I am stuck and not sure what to do.

1 Like

I have the same issue. Did you find any workaround/solution for that problem?

First I had the problem “Cannot update settings. Check you connection.”. After around 20 tries, I have now no error, but it gets back to the screen of adding device in Home app. Nothing appears in Home, but when I go to it is said that app is linked.

I tried to unlink and link again. Still the same problem - nothing happens in Home.

What version of are you running?

To get mine fixed I believe all I did was upgrade to the latest version of and got everything setup through the UI on under configuration > Home Assistant Cloud > Google Assistant > Manage Entities. I think I also had to unlink and relink the within the Google Home app. But now it works great and is even easier to use thanks to the UI in Home Assistant that allows for selecting of what is shown in Google Home.

I use latest Docker version - 0.99.1. I have also problems with menu option. It doesn’t appear at all (I tried to add discovery: and hassio: to configuration.yaml).