Problem with Blink Camera (can't connect to server..... I think)

I have been using the Script below to try and update my Blink Camera. When I try to run this, I get an error in my logs. I’m not very tech savvy with this stuff so I’m not sure what else to try or do. Thank you to anyone who takes the time to help.

blink_front_pic:
alias: Blink Front Door Pic
sequence:
service: blink.trigger_camera
data:
name: camera.blink_front_door

2018-11-01 17:30:50 ERROR (SyncWorker_14) [blinkpy.helpers.util] Cannot connect to server with url https://rest.u002.immedia-semi.com/events/network/23395.

What version of home-assistant are you on? Is that the only warning/error in your log related to Blink?

2018-11-06 11:22:40 ERROR (SyncWorker_3) [blinkpy.helpers.util] Cannot connect to server with url https://rest.u002.immedia-semi.com/events/network/23395.
2018-11-06 16:02:17 ERROR (SyncWorker_16) [blinkpy.helpers.util] Cannot connect to server with url https://rest.u002.immedia-semi.com/events/network/23395.
2018-11-06 16:19:50 ERROR (SyncWorker_9) [blinkpy.helpers.util] Cannot connect to server with url https://rest.u002.immedia-semi.com/events/network/23395.

Cannot connect to server with url https://rest.u002.immedia-semi.com/events/network/23395.

4:19 PM components/alarm_control_panel/blink.py (ERROR)

I am on Version 81.6

As far as I know these are the only errors I am getting, I’m not very “code-literate”. If I take a new picture with the Blink app, everything in Home Assistant updates no problem (Pictures & Sensors), but when I try running my script from my 1st post, I get the above errors. Thanks for taking the time to help with this.

OK, a few more questions:

  • How many sync modules do you have?

  • If you open the full home-assistant log (the little refresh-looking icon at the bottom right of the log section in the frontend) do you also see something that looks like
    INFO [blinkpy.helpers.util] Auth token expired, attempting re-authorization

  • If yes to the above question, do you see the following immediately after that log message?
    ERROR [blinkpy.helpers.util] Cannot obtain new token for server auth.

  • If you answered no to that last question, is your blink camera updating in the front-end? Or is it not updating at all (for easy testing, just take a new picture with the blink app, call the blink.blink_update service, and see if the display image for your camera updates in the home assistant front-end).

1 sync module, 2 blink cameras. When using Blink App, pictures and sensors both update in HA frontend.

I restarted then tried running my Blink Script, also tried Arm Home and Arm Away. Below is everything from my logs.

2018-11-06 17:45:10 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/helpers/service.py”, line 224, in _handle_service_platform_call
await getattr(entity, func)(**data)
File “/usr/local/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/alarm_control_panel/init.py”, line 105, in alarm_arm_home
raise NotImplementedError()
NotImplementedError

i just ran my script several times, nothing new is showing up in my logs, nothing seems to happen at all.

Arm Home isn’t implemented, which is exactly what that log entry means, so that’s ok.

When you use the Arm Away feature, does the Blink system actually arm (after setting arm away look in the blink app. It will take a bit to show if it worked so give it a minute)? Nothing showing up in your logs is a good thing, but nothing happening AND nothing in your logs doesn’t make sense.

When you run your script- what are you expecting to happen? The trigger cameras service is not instantaneous since Blink servers are polled at a certain interval (one minute by default) so are you waiting long enough? You could call the blink.blink_update service to force any update sooner than what would normally be scheduled if you want it to be instant.

EDIT - oh, wait your script is wrong. Name should be the actual name of the camera, not the entity id

IT WORKS!!! changed the script to

blink_front_door:
alias: Blink Front Door Pic
sequence:
service: blink.trigger_camera
data:
name: Front Door

and everything updated about 45 seconds later. Sensors and Picture in front-end. I really appreciate you taking the time to walk me through this. And Thank You for all the work/time/effort you put into this component as a whole. Thank you!!

1 Like

Log Details (ERROR)

Sat Nov 10 2018 18:00:02 GMT-0800 (Pacific Standard Time)

Cannot obtain new token for server auth. Please report this issue on https://github.com/fronzbot/blinkpy

Im now getting this error in my logs, had appeared several times. I also reported it as a issue on github, but figured Id let you know here as well.

Thank you.