Problem with configuring KNX (pi4/knxd/hassbian)

Hi,
I’ve set up Hassbian on Pi4, together with KNXD (connected to GIRA USB) to automate my lighting.

Unfortunately it doesn’t work.

The KNXD seems to work properly, the bus monitor shows the KNX events:

[email protected]:~ $ knxtool vbusmonitor1 ip:localhost
LPDU: BC 00 04 09 13 E1 00 80 3C :L_Data low from 0.0.4 to 1/1/19 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write (small) 00
LPDU: BC 00 05 09 13 E1 00 81 3C :L_Data low from 0.0.5 to 1/1/19 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write (small) 01
LPDU: BC 11 0F 09 13 E1 00 80 26 :L_Data low from 1.1.15 to 1/1/19 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write (small) 00
LPDU: BC 11 0F 09 14 E1 00 80 21 :L_Data low from 1.1.15 to 1/1/20 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write (small) 00

and I can use knxtool to send events to turn lights on/off:
knxtool groupswrite ip:localhost 1/1/19 0

I tried both type of connection in configuration.yaml:

knx:
    tunneling:
        host: 127.0.0.1
        port: 6720

The tunelling doesn’t work, the log doesn’t show anything special (/home/homeassistant/.homeassistant/home-assistant.log, even in debug mode), but the UI communicates: Can’t connect to KNX interface: Could not establish connection

The routing connection didn’t show any errors:

knx:
   routing:
      local_ip: 127.0.0.1

However, my light:

light:
  - platform: knx
    name: Gabinet.Light-Sufit
    address: '1/1/19'

doesn’t work. Changing the switch does not have any effect on the light itself, however it logs some messages that would suggest that the knx packet gets sent:

2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.2605856048] Received {'type': 'call_service', 'domain': 'light', 'service': 'turn_off', 'service_data': {'entity_id': 'light.gabinet_light_sufit'}, 'id': 20}
2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=light, service=turn_off, service_data=entity_id=light.gabinet_light_sufit>
2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event state_changed[L]: entity_id=light.gabinet_light_sufit, old_state=<state light.gabinet_light_sufit=on; friendly_name=Gabinet.Light-Sufit, supported_features=0 @ 2019-08-28T08:42:26.478364+02:00>, new_state=<state light.gabinet_light_sufit=off; friendly_name=Gabinet.Light-Sufit, supported_features=0 @ 2019-08-28T08:42:35.560828+02:00>>
2019-08-28 07:42:35 DEBUG (MainThread) [xknx.telegram] <Telegram group_address="GroupAddress("1/1/19")", payload="<DPTBinary value="False" />" telegramtype="TelegramType.GROUP_WRITE" direction="TelegramDirection.OUTGOING" />
2019-08-28 07:42:35 DEBUG (MainThread) [xknx.knx] Sending: <KNXIPFrame <KNXIPHeader HeaderLength="6" ProtocolVersion="16" KNXIPServiceType="KNXIPServiceType.ROUTING_INDICATION" Reserve="0" TotalLength="17" />
 body="<CEMIFrame SourceAddress="PhysicalAddress("15.15.250")" DestinationAddress="GroupAddress("1/1/19")" Flags="1011110011100000" Command="APCICommand.GROUP_WRITE" payload="<DPTBinary value="False" />" />" />
2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event state_changed[L]: entity_id=group.all_lights, old_state=<state group.all_lights=on; entity_id=('light.gabinet_light_sufit',), order=1, auto=True, friendly_name=all lights, hidden=True @ 2019-08-28T08:42:26.492183+02:00>, new_state=<state group.all_lights=off; entity_id=('light.gabinet_light_sufit',), order=1, auto=True, friendly_name=all lights, hidden=True @ 2019-08-28T08:42:35.571075+02:00>>
2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.2606997296] Sending {'id': 2, 'type': 'event', 'event': <Event state_changed[L]: entity_id=light.gabinet_light_sufit, old_state=<state light.gabinet_light_sufit=on; friendly_name=Gabinet.Light-Sufit, supported_features=0 @ 2019-08-28T08:42:26.478364+02:00>, new_state=<state light.gabinet_light_sufit=off; friendly_name=Gabinet.Light-Sufit, supported_features=0 @ 2019-08-28T08:42:35.560828+02:00>>}
2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.2605856048] Sending {'id': 2, 'type': 'event', 'event': <Event state_changed[L]: entity_id=light.gabinet_light_sufit, old_state=<state light.gabinet_light_sufit=on; friendly_name=Gabinet.Light-Sufit, supported_features=0 @ 2019-08-28T08:42:26.478364+02:00>, new_state=<state light.gabinet_light_sufit=off; friendly_name=Gabinet.Light-Sufit, supported_features=0 @ 2019-08-28T08:42:35.560828+02:00>>}
2019-08-28 07:42:35 DEBUG (MainThread) [xknx.knx] Received: <KNXIPFrame <KNXIPHeader HeaderLength="6" ProtocolVersion="16" KNXIPServiceType="KNXIPServiceType.ROUTING_INDICATION" Reserve="0" TotalLength="17" />
 body="<CEMIFrame SourceAddress="PhysicalAddress("15.15.250")" DestinationAddress="GroupAddress("1/1/19")" Flags="1011110011100000" Command="APCICommand.GROUP_WRITE" payload="<DPTBinary value="0" />" />" />
2019-08-28 07:42:35 DEBUG (MainThread) [xknx.log] Ignoring own packet
2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.2606997296] Sending {'id': 2, 'type': 'event', 'event': <Event state_changed[L]: entity_id=group.all_lights, old_state=<state group.all_lights=on; entity_id=('light.gabinet_light_sufit',), order=1, auto=True, friendly_name=all lights, hidden=True @ 2019-08-28T08:42:26.492183+02:00>, new_state=<state group.all_lights=off; entity_id=('light.gabinet_light_sufit',), order=1, auto=True, friendly_name=all lights, hidden=True @ 2019-08-28T08:42:35.571075+02:00>>}
2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.2605856048] Sending {'id': 2, 'type': 'event', 'event': <Event state_changed[L]: entity_id=group.all_lights, old_state=<state group.all_lights=on; entity_id=('light.gabinet_light_sufit',), order=1, auto=True, friendly_name=all lights, hidden=True @ 2019-08-28T08:42:26.492183+02:00>, new_state=<state group.all_lights=off; entity_id=('light.gabinet_light_sufit',), order=1, auto=True, friendly_name=all lights, hidden=True @ 2019-08-28T08:42:35.571075+02:00>>}
2019-08-28 07:42:35 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.2605856048] Sending {'id': 20, 'type': 'result', 'success': True, 'result': None}

There is also a problem with reading the state from KNX bus - the knxtool vbusmonitor can see the events, but HA don’t (at least no entries get logged when I turn on/off the light manually by the wall switch).

Could you please help me track the cause of the problem?
Thanks!

OK, problem seems to be solved. My KNXD didn’t have a tunneling options turned on:
Changing /etc/knxd.conf

from: KNXD_OPTS="-e 1.1.128 -E 1.1.129:8 -d -D -T -R -S -i --listen-local=/tmp/knx -b usb:"
to: KNXD_OPTS="-e 0.0.100 -E 15.15.245:8 -u /tmp/eib -i -b usb: --Discovery --Tunnelling --Routing --Server"

solved the problem.