Problem with new transmission component


I have installed the latest version 0.87 in Hassio and when I set the transmission component I do not see the turtle mode switch. It doesn’t allow me to configure the scan interval, it always gives me an error. All other things works fine…As I have seen, it also happens to a lot of people in the telegram groups, which may be happening? bug?

thanks a lot!
this is my configuration:

host: !secret trans_host
name: nuk
username: !secret transusername
password: !secret transpassword
turtle_mode: true #not work!! switch doesn't appears
# scan_interval: 60  #not work!! imposible to set
  - 'current_status'
  - 'download_speed'
  - 'upload_speed'
  - 'active_torrents'
  - 'paused_torrents'
  - 'total_torrents'
  - 'started_torrents'
  - 'completed_torrents'


I updated to 0.87 and after following the documentation, changed my configs and mine is working.

host: !secret transmission_server
username: !secret transmission_username
password: !secret transmission_password
  - 'current_status'
  - 'download_speed'
  - 'upload_speed'
  - 'active_torrents'
  - 'paused_torrents'
  - 'total_torrents'
  - 'started_torrents'
  - 'completed_torrents'
turtle_mode: true

Resulting entities are as follows:-

  • sensor.transmission_down_speed
  • sensor.transmission_up_speed
  • sensor.transmission_status
  • sensor.transmission_completed_torrents
  • sensor.transmission_started_torrents
  • sensor.transmission_paused_torrents
  • sensor.transmission_total_torrents
  • sensor.transmission_active_torrents
  • switch.transmission


thanks for your help but
same configuration as you
the switch still does not appear and the scan interval does not work fails when validating the configuration
Im sure thas its a bug, wait to the next release

Invalid config for [transmission]: [scan_interval] is an invalid option for [transmission]. Check: transmission->transmission->scan_interval. (See /config/configuration.yaml, line 38). Please check the docs at



It happens to me the same as the user sagatxxx, the parameters do not work:


Use last transmission version 2.94 although with 2.92 it did not work either.

The rest well.


Well I just double checked and my turtle mode is there and working as expected.

I do remember that scan_interval caused a validation error for me, so I did remove that.


… and I just updated my HassOS version to the latest (2.8) and the turtle switch has disappeared! No other changes. Suspect you are 100% correct - bug.

Apologies for giving you the run around - it was not intentional :frowning:


… and a couple of HA restarts later and the turtle mode switch is now back - no changes.

Anyway, 0.87.1 is out and it includes a fix for the scan_interval issue apparently. I haven’t installed the update yet as I am on HASSIO and still waiting for it to become available for that.


I’m using Hassio, updated to 87.0 the other day and the switch.transmission appeared for a short time then disappeared. 87.1 just appeared, I updated, restarted twice, still no switch.transmission.



It’s a very strange incidence.
I never see the switch of the turtle.

I will try with version 87.1 to see if there is more luck, although some user has already said that it does not appear either.

Precisely it is the most interesting functionality, in my opinion.

aheath, thanks for the tests and the answers and sorry for my bad English.


sure is a bug in my opinion, the scan interval has been fixed with version 0.87.1 but the switch seems not, in one of my multiple reboots I have come to see it working, with a lot of lag, but after restart it has disappeared again


Confirmed, in 0.87.1 it does not work either.

It seems that they already have it solution for the next version:


I’d setup the new Transmission component (turtle mode: true) and there isn’t a turtle mode switch for me as well.


Confirmed, in next version this problem is solved.


If you want to advance the solution, you must copy the 3 files of the repository in your installation:


many thanks, but how can I do it in Hassio?