Home Assistant Community

Problem with new transmission component

#1

I have installed the latest version 0.87 in Hassio and when I set the transmission component I do not see the turtle mode switch. It doesn’t allow me to configure the scan interval, it always gives me an error. All other things works fine…As I have seen, it also happens to a lot of people in the telegram groups, which may be happening? bug?

thanks a lot!
this is my configuration:

host: !secret trans_host
name: nuk
username: !secret transusername
password: !secret transpassword
turtle_mode: true #not work!! switch doesn't appears
# scan_interval: 60  #not work!! imposible to set
monitored_conditions:
  - 'current_status'
  - 'download_speed'
  - 'upload_speed'
  - 'active_torrents'
  - 'paused_torrents'
  - 'total_torrents'
  - 'started_torrents'
  - 'completed_torrents'
0 Likes

#2

I updated to 0.87 and after following the documentation, changed my configs and mine is working.

host: !secret transmission_server
username: !secret transmission_username
password: !secret transmission_password
monitored_conditions:
  - 'current_status'
  - 'download_speed'
  - 'upload_speed'
  - 'active_torrents'
  - 'paused_torrents'
  - 'total_torrents'
  - 'started_torrents'
  - 'completed_torrents'
turtle_mode: true

Resulting entities are as follows:-

  • sensor.transmission_down_speed
  • sensor.transmission_up_speed
  • sensor.transmission_status
  • sensor.transmission_completed_torrents
  • sensor.transmission_started_torrents
  • sensor.transmission_paused_torrents
  • sensor.transmission_total_torrents
  • sensor.transmission_active_torrents
  • switch.transmission
0 Likes

#3

thanks for your help but
same configuration as you
the switch still does not appear and the scan interval does not work fails when validating the configuration
Im sure thas its a bug, wait to the next release

Invalid config for [transmission]: [scan_interval] is an invalid option for [transmission]. Check: transmission->transmission->scan_interval. (See /config/configuration.yaml, line 38). Please check the docs at https://home-assistant.io/components/transmission/

0 Likes

#4

Hi.

It happens to me the same as the user sagatxxx, the parameters do not work:

turtle_mode
scan_interval

Use last transmission version 2.94 although with 2.92 it did not work either.

The rest well.

1 Like

#5

Well I just double checked and my turtle mode is there and working as expected.

I do remember that scan_interval caused a validation error for me, so I did remove that.

0 Likes

#6

… and I just updated my HassOS version to the latest (2.8) and the turtle switch has disappeared! No other changes. Suspect you are 100% correct - bug.

Apologies for giving you the run around - it was not intentional :frowning:

0 Likes

#7

… and a couple of HA restarts later and the turtle mode switch is now back - no changes.

Anyway, 0.87.1 is out and it includes a fix for the scan_interval issue apparently. I haven’t installed the update yet as I am on HASSIO and still waiting for it to become available for that.

0 Likes

#8

I’m using Hassio, updated to 87.0 the other day and the switch.transmission appeared for a short time then disappeared. 87.1 just appeared, I updated, restarted twice, still no switch.transmission.

0 Likes

#9

327/5000

It’s a very strange incidence.
I never see the switch of the turtle.

I will try with version 87.1 to see if there is more luck, although some user has already said that it does not appear either.

Precisely it is the most interesting functionality, in my opinion.

aheath, thanks for the tests and the answers and sorry for my bad English.

0 Likes

#10

sure is a bug in my opinion, the scan interval has been fixed with version 0.87.1 but the switch seems not, in one of my multiple reboots I have come to see it working, with a lot of lag, but after restart it has disappeared again

0 Likes

#11

Confirmed, in 0.87.1 it does not work either.

It seems that they already have it solution for the next version:

0 Likes

#12

I’d setup the new Transmission component (turtle mode: true) and there isn’t a turtle mode switch for me as well.

0 Likes

#13

Confirmed, in next version this problem is solved.

image

If you want to advance the solution, you must copy the 3 files of the repository in your installation:

0 Likes

#14

many thanks, but how can I do it in Hassio?

0 Likes

#15

I do not use Hass.io, I’m sorry.

0 Likes

#16

I don’t mean to hijack the thread, but is it possible to have multiple Transmission components configured? I run several instances of it and my previous sensors broke.

0 Likes

#17

Have you found a solution to the multiple instance problem?

0 Likes

#18

No, sadly. Transmission doesn’t scale well vertically, but it does a lovely job horizontally. I have ten Transmission docker containers seeding 18k torrents - the new component broke my automations around turning on turtle mode when Tautilli’s reported upload speed went past a certain threshold.

0 Likes