Problem with ONVIF Kamera ADD

Hi there,

I had to delete my garden camera and wanted to add it again because the ip has changed.

I can’t add it again because he always tells me the camera has already been added, but this is not true, under ONVIF in integrations I only have 1 device and that is my front camera.

I have configured everything via the web interface, can someone tell me how I can get the old one permanently deleted even though it is no longer there?

or what can I do now?

I’ve already deleted the whole integration myself and was able to reinsert the front door camera without any problems.

I also changed the onvif port several times, but it just doesn’t work anymore.


no one a idea?

Can you verify that the camera is broadcasting to 3rd party apps? You can use vlc or ONVIF Device Manager to make sure it’s streaming.

Yes its visible and broadcasting.
I can See the rtsp Stream too, but i always get the error that the camera is configured and exists

Just to be clear you’re adding manually, you go to the integrations page and hit add, then choose onvif, then put in the new IP address and it tells you the camera is already configured? If you enter a random ip does it give an error that no stream is found?

Yes correct.
When I choose a random ip he says me a error.

I deleted the complete onvif integration and make everything new, the other cam works always without problems, but the second one I get always the same error with , “is already configured”


Are they the same cameras? The firmware on the problematic one is older, is there anyway to update it?

until the ip change, everything works well. then the problems begun.

no differnt brands, but i think both cheap cameras, the webinterface looks the same.

this are cheap ip cameras i dont know if there are new Firmewares avaiable.
But the problem camera is the on the top, the firmeware is newer.

How about assigning another ip address? Or even going back to the old IP to see if the intgration shows up so you can try deleting it again. Was the IP defined in the camera settings? Is there a factory reset perhaps the config on the camera is not clearing and sending the old IP to onvif.

i tried it , gives the camera the old IP but i deletet the old camera in homeassistant, and when i try to add it again with the old ip, he says the same “device is alredy configured”.

i made a factory reset yesterday, but no luck.

i think its a homeassistant problem, with the mobile app on my phone and the rstp link everything works well

I’m at a loss, onvif is part of core and I’m not sure where it stores it’s configuration. I assume that is what you need to find and delete.

yeah, thats the way i think, do you know which one can i ask? or where?

or someone else?

bump bump bump

no one?

did you find out it? having the same issue :confused:

No only a complete new install helps me. But since the i have the problem, I configured my cameras manually over the configuration.yaml and this works until now.

I had a similar issue after “deleting” the existing ONVIF integration. Turned out I had only disabled it.

Check the top right part of the screen on the integrations page and look for "1 disabled - SHOW’. After showing, you can properly delete it. Afterwards I was able to re-add the camera again.