Problem with samba

Installed HA today on RP3.

My samba configs:

netbios name = CasaHubHA
server string = Home Assistant
workgroup = WORKGROUP

path = /home/homeassistant/.homeassistant
comment = HA
browsable = yes
read only = no
valid users =
writable = yes
guest ok = yes
public = yes
create mask = 0777
directory mask = 0777
force user = root
force create mode = 0777
force directory mode = 0777

But in my windows 10 network,i see the “CasaHubHa”, but inside don’t have any folder.

Where is the problem?

The Home Assistant configuration directory is hidden. You will have to click on show hidden files in windows file explorer.

I have box checked and still no folder.

Have you started Home Assistant? It won’t generate any configuration files until it has been started? Additionally, make sure the path is correct. Can you navigate there manually? What method of install did you use? Was it the All-In-One? If so, the path may be /home/hass/.homeassistant.

Yes the HA already started and works good.
I installed All-In-One, but after December 2016 the path is no more hass. Now is homeassistant.

The path is correct. I checked with filezilla.

Did you do a full reboot of your Pi after installing samba and creating the share? I think I always have needed a full boot to get everything working when setting it up the first time.

Yes restart samba service and full reboot.

new installation same problem. can’t see on windows or winscp.

what do you get when you

cd /etc/samba

I had the problem I could edit the file and sudo nano /etc/samba/smb.conf just created a new one my solution was

sudo service smbd stop
sudo nano /etc/samba/smb.conf
sudo service smbd start
1 Like

Hmm, have you seen this video? This is what I followed to get samba up and running. Other than needing a reboot the config has worked for me everytime Ive started fresh with HA.

I used this guide successfully too, but I ended up going to WinSCP instead for file management and editing.

Thanks!!! tThis solves the probem.
I have two smb.conf on the folder.

Thanks again mate

It is a great guide, but you do need to change the [Home Assistant] path from the one below the video to

path = /home/homeassistant/.homeassistant/

Otherwise, it will only be able to open the homepi directory and homeassistant will give an error.

1 Like

No worries Glad I could be on the other end and help a user out :smiley:

I had the same issue and doing this resolved it. thank you. :+1: