Problem with sftp access with SSH&Terminal addon

For more than one day I have struggled to enable SFTP access to my HA (hassio) system. I had this working on a virtual machine (hassio in hypervisor on Windows), but for some reason I can’t figure why it’s not working on my RPI4 (native hassio installation). I have copied my public key from my Windows SSH client and entered this in the SSH configuration, and I have no problem at all opening a SSH session from my Windows Command window. However, WinSCP gives me the error “No supported methods available (server sent: publickey,keyboard-interactive)”. I have enabled SFTP access in the SSH configuration and username root. I have even tried to specify a password without success. WinSCP gives the same error message.

Please see my enclosed SSH configuration. Any help is appreciated. This is almost driving me crazy.

apks: []
authorized_keys:  **** key ****
password: ''
   tcp_forwarding: false
username: root
sftp: true
compatibility_mode: true

Unfortunately, no help on this subject until now. New posts arrive at quite high frequency, so I have to bump and hope for someone will notice this…

Scroll down and double check that port 22. Also, you can try just using a password in stead of the key.

It’s not usually the done thing on a forum to bump before 24 hours.

Have you tried another user?

Can you try running sftp from the command line? Or scp?

Sorry, I’m travelling right now and can’t do so much more about this. Hoped for a solution before I have left. That’s why I was so eager to solve my problem.

I have port 22 configured, and yes I have tried password without success (I think I mentioned that in my post).

No, I haven’t tried with sftp or scp from command line. Will do this as soon as I get a chance. I have not tried with another user than root, since the documentation states I must use root.

If you use commandline you can use verbose logging to get more detail of what is failing.

First I want to apologies I was a bit eager to find a solution for my problem. I was about to leave my home for a couple of days, and wanted to have sftp in place to be able to solve any potential issues during my abscence. Now I’m back again and made some tests from command line.

It turns out both scp and sftp works fine from command line! So obviously my problem is related to WinScp, not the server in HA. Strange. I haven’t had any problem with WinScp before. Never mind. Now I have a workaround until I figure out why WinScp fails.

Edit: WinScp logs gives the following info:

. 2022-04-24 06:49:17.522 Waiting for the server to continue with the initialization
! 2022-04-24 06:49:17.522 Using username "root".
. 2022-04-24 06:49:17.555 Detected network event
. 2022-04-24 06:49:17.555 Waiting for the server to continue with the initialization
. 2022-04-24 06:49:17.555 Server offered these authentication methods: publickey,keyboard-interactive
. 2022-04-24 06:49:17.555 Attempting keyboard-interactive authentication
. 2022-04-24 06:49:17.564 Detected network event
. 2022-04-24 06:49:17.564 Waiting for the server to continue with the initialization
. 2022-04-24 06:49:17.564 Server refused keyboard-interactive authentication
. 2022-04-24 06:49:17.564 Server offered these authentication methods: publickey,keyboard-interactive
. 2022-04-24 06:49:17.564 No supported authentication methods available (server sent: publickey,keyboard-interactive)
. 2022-04-24 06:49:17.564 Attempt to close connection due to fatal exception:
* 2022-04-24 06:49:17.564 No supported authentication methods available (server sent: publickey,keyboard-interactive)
. 2022-04-24 06:49:17.564 Closing connection.

For some reason it seems like the publickey authentication fails and WinScp tries with keyboard interactive authentication. However server refuses to use this method, but the previous line states it is supported. Looks fishy…

Edit2: Tried with CyberDuck in Windows 11. After a few attempts I realized CyberDuck did not find my private key, since this file i stored without file extension in Windows. I manually specified this file, and then it worked fine.

The ssh & webterminal addon is pretty up to date, and that includes encryption methods. I had trouble even getting ssh to connect to it from an older ubuntu machine.

Maybe winscp is using some outdated encryption. Is your winscp fully up to date?

Edit: I see you have compatibility mode set so this is probably not the issue.

Yes, I have the latest version of WinScp. And maybe this is the problem. I have used WinScp frequently to access different RPi’s running standard Raspbian (Debian) without any problem. Now I have the same problem with them as well. CyberDuck works fine…

Mine says it is
Check for Updates

New version 5.19.6 was released.

WinSCP 5.19.6 (2022-02-22)
In this release, WinSCP was updated to OpenSSL 1.1.1m and Expat 2.4.6. This version also includes updated German translation.

So that has been around for a while

Well, this is the version I have problems with. Is it Windows 11 that screws things up?

This is really weird. Seems like sftp access is unstable. Sometimes Cyberduck works, sometimes I get authentication error, or more precisely “No supported authentivation methods available”. WinScp does not work at all.

I wonder if anyone has managed to use WinScp (v5.19.6) on Windows 11 for HA access?

Hey, I have some difficulties to access via Cyberduck myself. The setup for ssh was already a pain in the a… but Cyberduck won’t accept the same input for a connection via sftp. How did you go on to establish the connection? I guess he has some problems with the private key, but I’m not sure wat it is. It only says every time: request failed.
Thank you.