Problem with sonoff mini DIY config

I flashed some sonoff nimi DIY with Tasmota-basic.bin file (Version is 6.6.0) But Mqtt discover isn’t working with it (Setoption19 1 on) not sure why… I have some sonoff mini devices flashed with tasmota-basic.bin too, but are version 8.1.0, and they was discovered fine. I tried to update by OTA to last binary, but bricked two devices, maybe due to 500k limit. So I decided to add it by yaml. This is my code

  - platform: mqtt
    unique_id: DVES_DFB204
    name: "Bedroom light"
    state_topic: "home/bedroom/switch1"
    command_topic: "home/bedroom/switch1/set"
      - topic: "home/bedroom/switch1/available"
    payload_on: "ON"
    payload_off: "OFF"
    state_on: "ON"
    state_off: "OFF"
    optimistic: false
    qos: 0
    retain: true

As I saw in home assistant MQTT help page. The entity now appears in my entities list, but is disabled. I read the mosquitto log, and the device seems to work fine.

1611585069: New connection from on port 1883.
[INFO] found Mosquitto on Home Assistant
1611585070: New client connected from as DVES_DFB204 (p2, c1, k30, u'Mosquitto').
1611585759: Saving in-memory database to /data/mosquitto.db.

What should I do wrong here?
Is there any updated bin file that don’t brick Sonon mini DIY devices? All are greater than 500k

Hi… what is the mqtt topic for this device? You can see this in the mqtt config page in the tasmota UI.

1 Like

You have to upgrade to the full tasmota.bin. Tasmota-basic.bin does not support auto-discovery.

Once flashed with tasmota-basic.bin, you can upgrade to tasmota.bin. Just use tasmota-minimal.bin in between.

Did you follow the correct upgrade path ?

1 Like

My fault… I updated directly from tasmota-basic.bin to last tasmota.bin. This bricked the devices.I fixed the devices flashing again soldering wires. Flashed last tasmota.bin directly with tasmotizer, and are working again, and now MQTT discover works.

Tried to flash from last tasmota.bin to tasmota-minimal.bin, and then full tasmota.bin, as you said, and worked. Thanks for your help, it’s solved now.