Problem with ssh onto hassio

I am running HA on a Pi 3 B+ with hassio. Everything seems to be working but when I try to ssh I get

C:\Users\login\.ssh> ssh [email protected]
Corrupted MAC on input.
ssh_dispatch_run_fatal: Connection to 192.168.0.10 port 22: message authentication code incorrect

Ive been using the setup for several months.

Any idea how to fix this?

From Reddit

ssh -m [email protected] [email protected]

6 Likes

@funkytwig I experienced the same issue after updating the SSH plugin on my hassio PC. I got exactly the same error message.

I have tried the solution from @DrCos and it works. Fantastic.

I have made it easier to create a config file in %systemdrive%%homepath%\.ssh containing the following:

host ha
   HostName 192.168.178.110 #whatever the ip address of your machine is
   User root #or hassio in your case
   Macs [email protected]

Now you can simply do ssh ha to connect to the hassio machine.

3 Likes

nice. Did not know you could do a ‘config’ file in .ssh
Kudos!

No need for hmacs in .ssh. One simple change in HA is all that’s required.

-goto Add-ons
-select “advanced ssh & web Terminal”
-click configure
-change the fields sftp and compatibility-mode to true

Then it works

For sftp to work you need to be root

2 Likes

I get that this is a workaround, but why did this happen in the first place? Should this have been a documented breaking change?

1 Like