Problem with Tracker platform: bt_home_hub_5

I’ve just got a new router, which is a BT home hub 5. I was previously using nmap scanning but now I’ve seen a platform for this router:

I’ve added the example to my config file, its even the same default host address.

However, I get the following in my error log:

16-07-19 21:35:15 homeassistant.components.device_tracker.bt_home_hub_5: Invalid response from Home Hub: <Response [404]>
16-07-19 21:35:15 homeassistant.components.device_tracker: Error setting up platform bt_home_hub_5

Can anyone help?


I get a similar problem with my home hub 5. The component seems to look for /nonAuth/home_status.xml which doesnt exist on my Home Hub.

I also get the same error message, does anyone know of a fix for this?


Anyone get this working, i still get a 404 from my home hub as its going to that “home_status.xml” not sure if its moved or changed but doesn’t look like that works for the link anymore.

Hi it seems I’ve got the same problem. Did anyone manage to solve this issue?

Same here for both BT home hubs and plusnet. the XML URL doesnt exist which is a shame. I wonder if the feature is removed or just the URL changed on some models?

Anyone was able to solve this issue?
Cannot make the device tracker work properly with this component?
I’m trying to track my iphone connected to this router.

I have just got to this issue as well