Problem with UI Lovelace Minimalist after update

Hello everyone!

Yesterday, I performed an update on my home assistant, and suddenly all my dashboard components encountered the same error. I’m using the Lovelace minimalist and writing the dashboard in .yaml. Suddenly, this error appeared everywhere:

I’m attempting to restore a backup, but so far, I haven’t had any luck rolling back. If anybody has experienced the same issue or knows what might be wrong, I would appreciate the support!

1 Like

I’m in the same situation and I don’t know what to do anymore… if you go back to a previous version the same thing keeps happening. I don’t understand anything. I hope someone can help us!

I just used a backup from a week ago, and it solved the issue. I believe that the problem lies in the core update. I will continue to use the backup for a while, hoping that the issue will be fixed shortly with other updates…

1 Like

it is impossible for me to go back since I don’t have backups of so many days…

For the future make sure you’ve got at least 2 or 3 backups lined up. A game-changer for this is setting up your backups with Home Assistant backups into Google Drive – it’s a total lifesaver. I’m still figuring out what went wrong, but if you’ve got any new info, don’t hesitate to drop it here! As a quick fix, you can switch to a Mushroom UI Controlled dashboard. That was my next approach if the backup fails until the next update rolls in to fix things up.

and how can I change my panel from total UI to mushroom?

It’s not a change in your original Dashboard, use the default UI Controller Panel Dashboard of your home-assistant instance. You could create a second dashboard with mushroom cards, kinda like the Lovelace style. The downside is, you lose a bit of flexibility in card configuration, and you’ll have to redo the whole dashboard. It could serve as a backup, though, in case Lovelace hits a rough patch down the road. For a detailed guide, check out Creating a Home Assistant Mobile Dashboard Easily!.

1 Like

After updating core there should also be an update available for minimalist. If not just restart your system once, so HACS can fetch the new updates.

negative, after the updates, I have nothing from the minimalist.

this was done before and I deleted it all to put the minimalist UI :frowning:

I think I’ll have to do it again and save it.

You will need to restart HA once again to fetch the updates in HACS for the new core version you are using. To verify, what version of minimalist are you running?

1 Like

v1.3.9 version on UI minimalist installed

Today i tried to update the Core and the issue reappeared, here’s the issue in the lovelace git for follow up, Failed to setup on HA Core 2024.1.2 · Issue #1441 · UI-Lovelace-Minimalist/UI (

Joaquin, make a new room card. Restart home assistant. Comment out new room card. Restart home assistant. Everything should populate back to normal.

Hi! Thanks for your reply! I appreciate your suggestion, and I did give it a shot. Unfortunately, I wasn’t able to restore everything back to normal…