Problem with zigbee coordinator

I am having a problem with my USB zigbee dongle , TI cc2531 that I bought from ebay and home assistant
I set up zigbee2mqtt addon using instructions. The cc2531 was already flashed.
the failure used to happen sometime after my Raspberry Pi 4-based HA was turned on. initially the green(led2) one would be blinking and the red led (led1) would be fully lit, after some time I noticed the led’s would be turned off. and I would see sth like the following in HA logs

2021-02-16 12:29:44 ERROR (MainThread) [zigpy.application] Couldn't start application
2021-02-16 12:29:44 ERROR (MainThread) [homeassistant.components.zha.core.gateway] Couldn't start Legacy TI_CC = Texas Instruments Z-Stack ZNP protocol: CC253x, CC26x2, CC13x2 coordinator
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/zha/core/", line 157, in async_initialize
    self.application_controller = await
  File "/usr/local/lib/python3.8/site-packages/zigpy/", line 69, in new
    await app.startup(auto_form)
  File "/usr/local/lib/python3.8/site-packages/zigpy_cc/zigbee/", line 95, in startup
    await self._api.request(Subsystem.SYS, "ping", {"capabilities": 1})
  File "/usr/local/lib/python3.8/site-packages/zigpy_cc/", line 117, in request
    return await self.request_raw(obj, waiter_id, expected_status)
  File "/usr/local/lib/python3.8/site-packages/zigpy_cc/", line 121, in request_raw
    return await self._request_raw(obj, waiter_id, expected_status)
  File "/usr/local/lib/python3.8/site-packages/zigpy_cc/", line 141, in _request_raw
    result = await waiter.wait()
  File "/usr/local/lib/python3.8/site-packages/zigpy_cc/", line 47, in wait
    return await asyncio.wait_for(self.future, self.timeout / 1000)
  File "/usr/local/lib/python3.8/asyncio/", line 501, in wait_for
    raise exceptions.TimeoutError()
2021-02-16 12:29:44 WARNING (MainThread) [homeassistant.config_entries] Config entry 'TI CC2531 USB CDC, s/n: __0X00124B0008C52703 - Texas Instruments' for zha integration not ready yet. Retrying in 80 seconds


[596456.451398] cdc_acm 1-1.2:1.0: failed to set dtr/rts
on the host kernel logs.

Right now, it has a solid red led, probably because I reset it.

Any suggestions?
I could upgrade to a more dependable zigbee usb dongle if that would help

I got the exact same problem and same message in dmesg. It worked on a Raspberry pi 3, but now that I use the Pi 4 it does this. Did you find any solution?

No, I could try repairing the zigbee lights sometime, but unsure if it would work. I have read sometimes reflashing the device solves problems

I bought a pre-flashed one… I ordered a debuger and cable and I’ll try that.

Reflashing solved it! I had to use the V3 image to support my Ikea tradfri plugs.