Problem with Zwave Inovelli LZW30-SN switch configuration

Hi, I have a Inovelli LZW30-SN switch that does not seem to work correctly in a three-way configuration with a dumb three way switch. According to the docs, the firmware update 1.17 for this switch was supposed to add a new configuration parameter 13 called “load type” which could possibly address my problem. My switch is running formware version 1.19 according to HA. But if I try to configure the parameters via the JS Zwave Device Configuration page, the parameter does not appear. I also tried setting the parameter via an automation but fails saying the parameter doesn’t exist.

Any ideas on how to set this parameter?



This is a z-wave JS software issue. Search if the issue is already open, if not open an issue here:

edit: I had to do a PR for the 31-SN to get 1.56 parameters changed/added. They are only incorporating non-beta (filed with z-wave) parameters and then end users have to add the code for parameter adds/changes with various firmware updates. Example:

Thanks for responding, but I’m still not quite sure what to do. Is this a Zwave JS issue or an HA issue? I’m happy to file a bug report but want to get it to the right place.



Have you tried to re-interview the node yet?

Freshcoat, I wish I knew what re-interviewing a node means. Sorry. :slight_smile:

Click the re-interview button.

Hmm… I only see the Configure Device option. No Reinterview option. Was it added this month? I’m still running 2021.4.6.


Yes, you would need to update to see it. The next question would be what version of Z-Wave JS are you using then? The project moves quickly, even a month can be quite out of date.

Thanks. I clearly need to stay on top of the updates…

No luck. Upgraded to the latest HA and am running ZwaveJS 0.1.21. Tried setting the parameter value to 13 and the error is:

zwave_js_server.exceptions.NotFoundError: Configuration parameter with value ID 53-112-0-13 could not be found

I also tried setting the parameter value to “Load Type” and got the error

zwave_js_server.exceptions.NotFoundError: Configuration parameter with parameter name Load Type could not be found

Thanks for helping, tho.


But did you perform the re-interview?

Yes. Updated HA and then re-interviewed.

What firmware are you running?

What do you see in the configure device for parameters? Specifically parameter 13?

Firmware version 1.9 on the switch. Neither parameter 13 nor 51 appear in the configure device page, and both those parameters have a test for the version number as part of the configuration. Don’t know if that makes a difference.

1.19, not 1.9 correct?

Switch and dimmer parameters are different, so just to be clear you are using the LZW30-SN Red Series On/Off Switch, yes?

Here is the parameter:

per Z-Wave JS Config DB Browser

Now, looking at the source code, they are both in the config for the LZW30-SN:

per node-zwave-js/lzw30-sn.json at 2f9a2198a1a8241cafcd8cd9705de4b34d6dd547 · zwave-js/node-zwave-js · GitHub

So, either it’s not detecting you are running 1.19, or HA is not refreshing the config based on a re-interview. I’d say the latter is probably the case. I recommend:

  1. Air gap the switch, wait 1 min for device to re-enter mesh.
  2. Re-interview the node
  3. Restart HA
  4. Check if the Configuration of the device now has Param 13 or 51.

The code is there and correct to the best of my knowledge.


First of all, thanks for all your help.
I am indeed trying to configure a LZW30-SN on/off switch.

Oddly, HA shows the firmware version of the device as 1.9 (see screenshot). I do not know what version the switch actually is running - is there another way to pull the firmware version from the switch? My suspicion is that it might be an older firmware version because I bought the switch right after they came out. No idea where the 1.9 is coming from.

I followed your steps to air gap the switch etc. but it didn’t affect the available config options.

Thanks again,


I’d report over on github and see what they have to say. I’m frankly out of ideas.