Problems after changing routers

As a lockdown project I set up Home Assistant over the last 6-8 months on a system with BT internet (UK), Netgear modem and Google Mesh Wifi Router and everything worked fine. Google seemed to handle all the HA external needs and my Nabu Casa link worked well, so I was oblivious to any specific router requirements. But for various reasons I have had to switch to the standard BT modem-router hub ( Smart Hub 2, wifi discs). I have managed to get my Home Assistant working again, copying the internal IP structure on BT that I had with Google Wifi (, but HA clearly isn’t communicating with the outside world as it isn’t configuring properly and I am getting error messages in the startup log which all seem to be associated with the need for external access. Elements of the default_config process are failing, as a result. For example;

Error requesting Home Assistant update data: Cannot connect to host ssl:default

The Nabu Cassa cloud login page has also vanished and several parts of the setup haven’t survived the transfer process. I think I may need to open some ports on my router for this to happen, but I am not clear what I have to do. While I had managed to set up a good HA dashboard and home control system, I remain a novice, especially with internet communication protocols.
Can anyone help? Thanks in advance, David

I have the same setup as you (Smart Hub 2, wifi discs), having changed from Plusnet and wifi discs recently. I didn’t have to do anything to the ports on the BT router.

One thing I did do was change the SSID and password on the new router so that they were the same as the three discs, to avoid issues with network logon.

1 Like