Problems connecting to


I was happy to see a z-way / integration in the new release. I cannot make the setup procedure work for me though. I set up a user for home assistant in zway, but actually, no user has a global API token that is mentioned in the configuration popup. The one key I do have starts with an “/” prefix, which is perhaps part of the key, but looks odd so I would be happy to learn if I should keep it or not when I enter the key into HA.

Skärmavbild 2022-03-07 kl. 19.52.21

Also, I am not sure whether one should use an ws:// protocol specification since my server does not have SSL encryption.

As a result I cannot log in to the system, and I get a “No valid UUID set” message whatever I do.

Any ideas?



I share your enthusiasm. Seems to be a bug and a patch available here No valid UUID set - forum

I am having same issue, when I try to integrate my Z-WAVE to HA I get the error “UUID not set”
Have already checked the link you shared above about a bug, but there it says this is no longer needed.
However I am not able to install that patch on my Z-WAVE as I am not able to ssh into it.
I have created new users on my Z-WAVE device and tried with new token, but no success, maybe someone could help here with this.

This should be solved in the new Z-Way v4.0.2. If you still experience this issue, please share logs or contact the support team (

thanks for your answer, you are right it is solved in Z-Wave v4.02, but Rehau has not released that update on their device and that is the problem. In the meantime I sent it back to them and bought a Z-Wave Stick 7, connected that to my HA and that works