Problems including new z-wave devices

Hey all,

after just reading the community forum for month the time has come to ask the community for help: I have serious problems adding new devices to my setup. Also it seems that the z-wave network ist quite slow.

My setup:

  • Raspberry Pi 4B/4GB
  • RaZberry ZM5202 based controller
  • Home Assistant 2021.9.5
  • Official Z-Wave JS integration and add-on
  • 53 active nodes (Eurotronic Spirit Z-Wave Plus, ABUS SHRM10000, Fibaro FGS223/FGMS0001/FGWP102, AEON Labs ZW100/ZW095)
  • Devices spread around the whole house (several rooms and floors) with several non-battery-devices

Observations:

  • Changing heating modes changes the thermostat nearly immediately (1-2 seconds), but the changed setting is show in Home Assistant at the earliest after 5 seconds. This has been different before (other setup, maybe less devices, but it was possilble really immediately)
  • Some battery devices are showing 0% battery level even with new batteries. This happened before right after changing the batteries, but settled within the first day. Since some weeks the are several devices showing 0% all the time (some Eurotronic Spirit and one Fibaro Magic Eye)

Problem:

  • Including new devices does not work at all. Last success was including another SHRM10000 smoke detector. After including timed out, I waited some 10 seconds until a new (unidentified) device showed up. After some trying (re-interview, re-inserting battery, pushing buttons) the interview completed and the device showed up as wanted. I have some more devices that I cannot include in my setup (ABUS CFA3010, Sensative Strips Guard, ABUS SHRM10000, Fibaro FGS223)
  • There is not difference trying to include devices right next to the controller (basement) or from my working room.
  • I tried including a new SHRM10000 (debug log linked below). Including started at 18:57:39, at 18:57:50 the SHRM10000 stopped blinking (including completed?), at 18:59:10 Home Assistant including process ended with any information and after some more seconds a new device showed up in the list (node 128) with ‘node status’=dead and ‘node ready’=no without any manufacturer/model information and without any entities (only entity node_status is deactivated)

So any idea what could be the problem here or how to debug this any further? The debug log can be found here.

Thx in advance for any help and/or advice!
Wolfgang

1 Like

You have nodes sending constant power management reports. Looks like node 76 is reporting power every 5 seconds.

Seems like the network is being overwhelmed by these reports. What are those devices? Do you need those power reports or can you at least decrease their frequency?

Also, once you do get the issue straightened out, I’d be sure to change logging back to “info”. I left logging on and once I turned it off saw speed improve a lot.

1 Like

Node 76 is the energy meter for the full house. I’ll reduce the reports to see if there is any effect.

I change the logging only on-demand in the integration configuration. For my understanding it is changed back to default “info” once I leave the tab, or am I wrong with this?

Yeah I was having trouble with some energy monitoring switches, and things improved a lot when I disabled ones I don’t need and decreased the frequency on others.

For the logging, I checked on the integration and changed to “info”, closed the tab and app, and it was still info when I went back.

You want it just on “warn” during normal operation and not troubleshooting.

I changed the reporting intervals/tresholds to some higher values (less reporting) and changed the logging level at both integration and addon config to “warn”. Still the same problem trying to include a new SHRM10000: including stops without any result, several (~20-30) seconds later a new node shows up, “dead” and “not ready”. Exclusion does not work, therefore I have to remove the failed device and hard reset it.

My node id for new devices is at 130 now with 53 active devices, could this cause the problems?

Are there any recommendations for good working/good supported z-wave controllers? In the beginning I thought a GPIO device would be good but now I just want to have a working z-wave network.

Another silly log during normal operation (5mins). Seems not like too much traffic in my opinion, I still don’t understand why inclusion is not working in my setup :frowning: .

There’s been some bugs around inclusion that hopefully have been fixed

Are you running the latest version of the addon?

I also see some security errors on nodes 19 and 20, what are those? Have you changed your security key lately? Do they need security? You may need to remove and reinclude. You should include everything with no security unless it’s a door lock. S0 security uses a ton of bandwidth and should only be used if absolutely necessary.

This won’t impact anything. Zwave uses a 2 digit hex number for node id’s- 255 total numbers can be made with a 2 digit hex number. Once it cycles through all 250 some numbers sequentially, it will restart using old skipped ones.

These are two thermostats, should not be included as secure devices. Where can I verify this?

No, should have been the same since the last full new deployment including controller reset and new include for every device .

I have a new door lock which I’m not able to include yet, so yes.

Good to know :+1:

  • Z-Wave JS Add-on 0.1.39
  • Z-Wave JS driver version 8.2.3
  • Z-Wave JS server version 1.10.3

There is a settings dump file in JSON format you can download

Screenshot from 2021-09-11 09-00-24

Once downloaded, do a search in the file for - ’ “nodeId”: 19 ’
There will be a field under it isSecure = true, false, or unknown

If it says true or unkwown, the security isn’t right and you should exclude and reinclude the device.

I know this must be frustrating. Generally, the way I’ve dealt with issues like yours is to try and remove devices that could potentially be causing problems from the network and see if things stabilize to narrow things down. Those are generally devices with too many log entries or errors in log entries. A device with security mismatch or wrong security will definitely cause issues throughout the network. Zwave is pretty low bandwith and bottlenecks impact the whole network. The problem is compounded usually because if commands don’t make it sometimes devices “panic” and flood the network with even more commands.

Unfortunately though we can’t rule out an issue/bug with the program itself, and there have been a lot of bugs around inclusion lately with zwavejs. It looks like you have the latest versions of everything to me. If ultimately you can’t get any devices to include after troubleshooting and cleaning out problem devices/updating settings, you’ll probably have to file a github issue. Start with filing it through Home Assistant’s github page first, since I don’t know if the issue is the integration, addon, or zwavejs itself. Make sure you follow all the directions and attach any applicable logs.

My nodes were all “true” or “unknown”. Today I excluded every “true”-device and re-included them. Now 6 devices are “false” and 38 “unknown”.
Main problem now: including more devices does not work anymore :frowning: . I’ve put the devices back to their proper location now and will do a network heal for re-rerouting.
I’ll try to exclude some devices which I did not exlude today in the next days. If there is a faulty device affecting the whole network I hopefully will find it.

Sorry I should have been a little clearer on the “unknown”- it really applied to the two thermostats since they were sending encapsulated messages and nonce reports- which is what securely included devices do. I wouldn’t worry about the “unknown” on other devices too much that aren’t generating log issues.

It’s weird you can exclude and reinclude devices that were already attached, but no additional new ones.

Does your heal ever complete successfully or does it just seem to get stuck?

You also may want to look into switching to the zwavejs2mqtt community addon instead. It gives you additional functionality including healing individual nodes vs the whole network, and it’s own control panel. I run it instead of the zwavejs addon.

Here’s instructions to install it if interested

Sry for the late response, I’ve been quite busy the last days. I did some more testing yesterday.

I’m not even able the re-include all devices I excluded, I’m still missing some thermostats. It seems to be quite luck, the including process in HA ends, but I cannot see the interview. In the node list there is a new e. g. “node 156”, but “dead” or “not ready”. After a while the node is detected as expected. With my smart lock there has been some basic detection two weeks ago, yesterday I was not able the see it at all with several tries.

I’ve been using this in the beginning but changed to the official addon later as it supports all the features I need (including healing individual nodes by now) and because I wanted to assure that there are no compatibility issues at all. If I understand you correctly there should not be any difference in performance or compatiblilty, even more functionality.

I just ordered a Aeotec Z-Stick 7 which seems to be well supported with HA. If I have to remove every single device from my controller anyway for further troubleshooting I will use the opportunity to change from GPIO to USB and update to Z-Wave Gen7 for future use. I’ll let you know about my findings.

Thx and regards!

It still just sounds like a “traffic jam” or routing issue. I’m not sure if a new zstick will fix the problem, but hopefully it helps, and who’s like to hear how it goes.

What zwave hub were you on before Home Assistant? Did you have any issues with it or was everything working fine? A lot of times unresolved zwave issues just carry over.

As far as the whole zwavejs vs zwavejs2mqtt they continue to add more functions to the integration control panel, like heal node us there now, but its still not up to par with everything in zwavejs2mqtt. You can’t set associations, can’t do a custom/modified device config, or set custom parameters in the zwavejs control panel either.

I have to use zwavejs2mqtt since I use home assistant container so I don’t have an option really (no included addons). However, if anyone with a hassio/supervised install asks if they should use zwavejs or zwavejs2mqtt , I would say zwavejs2mqtt. This is at least until everything is available to control and set directly though the zwavejs integration. Once that parity is achieved then it won’t really matter which one you use. If you don’t need these extra features I agree, probably not worth switching an existing install, but if you’re starting over with a new zstick anyway, I would strongly consider it.

They also both use the same underlying zwavejs server, so there wouldn’t be a compatibility issue. One could also argue the mqtt part of zwavejs2mqtt is a more universal standard that could better future proof your install versus using the websocket integration that just works only with Home Assistant.

Hi,

yeah I still wonder why the logs do not show too much traffic or any further troubleshooting guidance/direction. Anyway I’ll give it a fresh start and hope there will be a single device which leads to instant lags rather than small problems with many devices of a kind.

I used openHAB for some years also with the RaZberry board. Not sure when the problems started (yes, I had them with openHAB also, but less devices and less problems) but I did a full re-include of all devices last year around the time I switched to HomeAssistant. But it’s a good hint, maybe I have to look after my “old” devices at first :slight_smile: .

Ok sounds great, I’ll give it another try.

Thx and regards :slight_smile:

Hi,

wow it has been a while, I had some other priorities to take care of :slight_smile:.

In the meanwhile I changed the controller to a Aeotec Z-Stick 7/zwavejs2mqtt and added some devices. Quickly the “network heal” was not succeeding any more, anyhow the performance of the network was still fine. So I reduced the number of devices again to find a setup, which with the “network heal” will succeed. With only three Fibaro relays it was working. After adding two more relays (same model) the heal failed. Now I have a new setup with three different devices (no Fibaro), and it still fails, starting with a Aeotec Home Energy Meter.

Is there any other test I can perform to ensure network reliability and performance? I am afraid there is a generel problem with a device model unlike a single device, which will be hard to identify :frowning: .

Thx and BR
Wolfgang

This runs a 700 chip.

So it unfortunately it (the inability to run a successful heal) may be this: 🚧 META-Issue: Problems with 700 series (healing, delays, neighbors, ...) 🚧 · Issue #3906 · zwave-js/node-zwave-js · GitHub

I just downgraded my 700 based stick to a 500 based Aeotek5+ last week. Still fighing a few minor issues but stuff isn’t magically dropping anymore…

1 Like

Thanks for the info @NathanCu . This issue would definitely have me second guess the 700 series chip right now until things are sorted out.

1 Like

Hi

Thx, at least a solid bug and not an extraordinary problem ^^.

I think I’ll switch back to my RazBerry until the problem is fixed. Thank you very much, I didn’t expect a new problem here.

Best regards
Wolfgang