Problems Installing HACS

I am fairly new to HA and I have it installed on a Ubuntu Server 20.4 in Docker. I have tried to install HACS but keep running into install errors. When I try and install via the SSH method, it tells me it can’t find the directory and to manually change the directory to the HA directory. But when I try and cd into the folder, I get an error that the directory doesn’t exist. If I try and use winSCP I get permission denied errors when I try and create folders and paste files. I believe this is due to the owner of the custom_components folder I created is my user account and everything from the Docker folder on is owned by root.

Can anyone give me some guidance how to get past these issues and complete the install? I have googled all the errors I get but I haven’t been able to find any answers that solve the problems.

Are you mounting the HA config directory as a local volume? You should be able to simply ssh into your ubuntu server and cd to that local directory to create your custom_components folder.
Snippet from my docker-compose.yaml:

  homeassistant:
    container_name: home-assistant
    volumes:
      - ${USERDIR}/docker/homeassistant:/config

I can SSH into the server but I get an error when I run the install script. When I try and cd down to the folder where the config.yaml file is located, I get an error saying the directory does not exist. This starts at /home/user/docker folder. I was able to create the custom_components folder using the file editor in HA but I am unable to put the hacs folder inside of it.

What docker command are you using to run HA? What install script are you using? As far as I know there is no install script to install HACS, you just unzip a file and place it in your custom_components directory and restart.

I was following the instructions on the HACS install site. curl -sfSL https://hacs.xyz/install | bash -

Ah, sorry I didn’t realize they had added an install script. I’m still not clear on how HA is running. Are you running a docker command from your ubuntu sever machine to run the container, or are you using docker-compose?

Being new to linux and docker in general I dont know what the differences are. However, I was able to figure out the problem. Apparently when I reinstalled Ubuntu, it kept the previous settings (I was trying a fresh new install), so when I made a user account during setup, it was not the default user that was setup and thus, the new user account did not have permissions to the core folders. Once I gave the original user password, all worked fine and I was able to install HACS. Thanks for the help!

Glad you got it working!