Problems logging in with MyQ component

The “/v4” in your error clearly indicates your installation has not been upgraded. If it were, HA would have updated the pymyq module to 2.0.0 which supports the V5 api. try restarting or rebooting. If you have access to your python environment supporting your HA installation, make sure you have pymyq 2.0.0 (HA should automatically bump it)

$ pip list |grep pymyq
pymyq                   2.0.0

This is broken for me too. I’m using and I upgraded to 0.100.3 today.

@krk628 I agree 100% with your assessment regarding the log message. As mentioned I have rebooted multiple times with the same error showing up in the logs every time. I have run your instruction and get no information.

I’m definitely no expert so please bear with me. I have checked the manifest.json file in the /config/custom_components/myq directory, the following version is 1.2.1 not 2.0.0. I suspect this is not correct. But as the files in the myq directory (I assume are loaded automatically), I’m not sure what to do.

Would changing the referenced version to 2.0.0. in the manifest.json file invoke HA to ‘pull’ the correct version ?

1 Like

It isn’t updating because you’re using a custom component. I recommend you uninstall the custom component and covert your configs to the normal out of box myq cover config. HA will see the normal config and pull down the pymyq module accordingly.

(Myq has been bundled since 0.39)


Thank you very much sir, you are a gentleman and a scholar. Followed your suggestion and the entity was created. Appreciate you help!!

1 Like

Same here…using 0.100.3 on hassio, still broken for me…

I’m also up to date and it’s not working for me. I’m going to attempt to update my firmware and reset if needed just for shits and giggles to see if it gets me anywhere.

I had to get out of bed and shut the garage door last night. It was awful. :rofl:

FYI: MYQ not working

I think I’ll wait for the next Hassio update with the fix, the alternative suggested seems to be somewhat daunting for the inexperienced i.e. me. It seems there is a need to disable protection mode on SSH and run some CLI commands. The commands are reference in the thread that @bachya just posted for those with a stronger stomach that I :wink:

I’m not sure if my way was “proper” or a “terrible idea” but I got it working on hassio.
The link above is much easier than the way I went, but I ssh’ed into my ubuntu server, used “find / -name pymyq” to find the name of the right docker container. I navigated to the pymyq library and made this change to the file and it started working.
I didnt mess with the manifest file.

1 Like

Just updated to hassio 0.101.0 supervisor version 192 and the MyQ component is still broken.

It’s fixed in 0.101.1

1 Like

Aren’t there other issues with 0.101.1? If not, I’ll go for it!

More issues with what? MyQ is working fine for me after this update.

I’m getting tired of this. Thinking about setting up the home assistant ADB component to send commands to an always connected spare Android device to open the MyQ App and simulate some touches. Anybody think of why this wouldn’t work/be a bad idea.

It’s working for me now on 0.101.2 but I had to delete the myq entries from the config/.storage/core.entity_registry file and restart hassio

1 Like

Mine just worked with the new 0.101.2 I was surprised how quickly the release from 0.100.0 updated, good job folks!

The only MyQ component is my single garage door opener. Last time I had to delete it because it was called garage_opener_2 that worked, but this time, it just worked and I didn’t need to delete anything.


That could work. You could probably do much the same using Tasker with an AutoInput/AutoRemote combo. I don’t know anything about sending ADB commands, so I have no idea which may be easier, but it’s a very interesting idea!

If your device is rooted autoinput is not required there are commands for input touch that I have used in the past to accomplish this

I was having trouble as well. I had a % in my password. Changed to all alphanumeric and it started working.