Problems restoring new backups

Tags: #<Tag:0x00007fc41d8cb548>

Today I attempted to restore a recent backup of last night, these are created automatically each night.
After restoring a partial I could not access the webgui, I tried to do a full restore ending up with the same result. Tried an other backup, few days old same result. I had to go back 4 weeks to get a working restore. Seems like the backup/restore is broken. I can restore addons from new backups this did not crash things, anything else breaks it.
This is from the console, these errors I did see return on each attempt after which HA halted. I can still access via SSH.
Anyone else running into these issues? It is really annoying and a concern something like the backup/restore is not working.

21-03-30 21:16:17 ERROR (MainThread) [supervisor.homeassistant.core] Home Assistant has crashed!
21-03-30 21:16:17 ERROR (MainThread) [supervisor.snapshots] Restore 7a28fcbe error
Traceback (most recent call last):
File “/usr/src/supervisor/supervisor/snapshots/init.py”, line 294, in do_restore_full
await self.sys_homeassistant.core.start()
File “/usr/src/supervisor/supervisor/utils/init.py”, line 32, in wrap_api
return await method(api, *args, **kwargs)
File “/usr/src/supervisor/supervisor/homeassistant/core.py”, line 273, in start
await self._start()
File “/usr/src/supervisor/supervisor/homeassistant/core.py”, line 254, in _start
await self._block_till_run(self.sys_homeassistant.version)
File “/usr/src/supervisor/supervisor/homeassistant/core.py”, line 431, in _block_till_run
raise HomeAssistantCrashError()
supervisor.exceptions.HomeAssistantCrashError
21-03-30 21:16:43 INFO (MainThread) [supervisor.api.security] /supervisor/logs access from a0d7b954_ssh