Problems setting up Pi-hole or AdGuard

When I had adguard installed on my Pi I just searched for blocklists on github.

For Example:

Don’t add too many blocklists though as it makes it a pain to troubleshoot.

If you want to run the one above you need to add this to your lists:

I would only run one list at a time until you get the hang of things.

1 Like

Just so people know, this works for OMV with no issues that I’ve found!
So I’ve finally got Adguard working again! :smiley:

1 Like

Did not get Pi-hole working in Docker. Disabled AdGuard, but the admin page does not show up.

Now enabled AdGuard. It seems to work, but statistics are not changing. I see in query log new sites appearing, but statistics is the same.
I have added few domais, that show me most ads, but it is not blocking them. Tried to even dublicate.

I can access Pi-hole only in HA, but it is a dead end as it is no longer supported…

I just used my phone to test adguard with default settings. Works. All Google ads are being blocked as far as I can see. Stats work also. Though the first time it didn’t work, but I soon realized my phone was still connected with my VPN. Are you sure you test device uses adguard as it’s DNS?

now it is working again. Took a break, and tested if I could get Pi-hole running - NO :smiley:

It is now blocking some of the stuff, but not all. As i can still see ads, and if I click on it, I see first and then i´am redirected to the page the ad was aboud.

Fond something from the AdGuard log

2020/04/15 17:51:02 [info] Couldn’t request filter from URL, skipping: Get read tcp> read: connection reset by peer
2020/04/15 17:51:02 [info] Failed to update filter Get read tcp> read: connection reset by peer

Switched off this list.

Try disabling all the lists and try the one I linked to above. Its an amalgamation of various other lists that wont interfere with each-other.
It’s been my go-to list since I used to just use a browser extension for Ad-blocking, then Pi-Hole, now AdGuard.

I´ll try. Added additional lists from Adguard web page.

My main problem might also be, that some of the webpages I am surfing are not in english.

But it does not block on facebook or youtube.

Facebook and Youtube are a nightmare to try and block.
The other thing is it may be pulling the adverts through on Cache if they are your usual websites you visit.
On a page with adverts (served from where you KNOW they are blocked) try pressing CTRL&F5. You may find they are hidden then.

point me to a extreamly adful webpage, you had good results with. I`ll test with 2 separate devices then every page :rofl::grin: Is the worst place. HOWEVER! I just tried it and discovered mine was still showing ads on there… So I added the only other blocklist I had previously:
(You need the second link in the description)

With those two lists (the one I linked previously, and this Orthrus one) running it comes up clean.

If you want to test go to ANY local newspaper website, they are all struggling in the age of the internet so have loooads of ads usually.

1 Like

Yep, this is what I had to do because systemd-resolved is a DNS service running on port 53. Just make sure your fix is still in place after reboot. I can’t remember what I had to do, because the service kept on restart at reboot.

I think it came in with Ububtu 18.04, not sure though, pretty much first time I have used Ubuntu in anger. Frustrates the hell out of me, can’t get VNC to work, just seems to be a known bug in Ubuntu…

1 Like

I am testing on Android device, not the usual page. - 2 phones side by side, no difference. few adds, none vere blocked

seems, it has stopped, as 197 is there for an hour already.

Got Pi-hole running on Docker.
followed these steps. Ports were wrong, took several tries.

1 Like

sudo systemctl disable systemd-resolved.service
That is the command to get rid of it permanently.

Thanks for these lists! Finally without stupid adds… Like they need it :rofl:

No problem, I’m still looking for the one I had like 3 builds ago. I literally only had the one blocklist and it contained around 300,000 Urls. It was perfect for my uses but never made a note of the name of it. I just remember it was from Github.

Ok guys (tagging @Coedy and @RogTP to make sure you see this), I just figured out that stopping the systemd-resolved service wasn’t the best solution. Because afterwards your systems can’t use any DNS anymore.
But I found a better solution. Make resolved not listen on port 53 while running.
Here are the steps:

  1. Edit (as root) /etc/systemd/resolved.conf and uncomment #DNSStubListener=yes and change it to #DNSStubListener=no
  2. sudo mv /etc/resolv.conf /etc/resolv.conf.OLD
  3. sudo ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf
  4. sudo systemctl start systemd-resolved.service
  5. sudo systemctl enable systemd-resolved.service

To test you can run ping before and after. Also it’s possible to start Adguard after this (or leave it running during this change.


To be honest I don’t remember what I did… Looks like I did point 1, but note it is still commented out. My /etc/resolv.conf is missing and systemd-resolved is disabled. When I do nmcli device show <interfacename> it shows I am using my Adguard instance as DNS.

It was a while ago now, so I suspect I did something else as well…