Problems since un-installing pi-Hole

Tags: #<Tag:0x00007f739b4c18a8>

Hey all,
I decided to uninstall pi-hole as its depreciated and give adguard a go. Since I uninstalled pihole the addon store fails to successfully install anything with an error ‘Failed to install addon, Unknown Error, see logs’

In the logs I am getting:

20-03-31 22:42:51 INFO (SyncWorker_0) [supervisor.docker.interface] Pull image hassioaddons/adguard-amd64 tag 2.3.3.
20-03-31 22:42:51 ERROR (SyncWorker_0) [supervisor.docker.interface] Can’t install hassioaddons/adguard-amd64:2.3.3 -> 500 Server Error: Internal Server Error (“Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:60490->[::1]:53: read: connection refused”).

Seems like I’ve buggered DNS and I am not sure how to fix it, any suggestions?

thanks
Gary

What is the dns set to in your router?

What are the DNS settings for Hass.io?

My router is set to my ISP dns and hassio appears to be set to 127.0.0.11

I tried adding ha dns --servers dns:\isp.ip too with no effect

G

Did you follow installation step 1 when installing the add-on?

Hassio shouldn’t be looking at itself for DNS requests.

What sort of crazy talk is this? pi-hole is not deprecated.

(BTW deprecated is the word you were looking for.)

The add-on is. Not pihole itself.

Ahh I understand. I don’t run it as an addon.

I have seen lots of references to adguard home. But when I go to their web page, I see “purchase” “license fees” and I run away.

I know, crazy! so much so that I spelled decapitated wrong! lol