Problems updating to HassOs 12.2 and core 2024.4.3

Hi all!
Let me start by saying that I have never had any problems updating Home Assistant.
Currently installed on a Raspberry Pi 4 are:

  • HassOS 12.2
  • Core 2024.3.1

And all add-ons and custom components are updated.

Last week I tried to install the “Core 2024.4.3” (without success) and… since then I have only had problems.
The installation seemed to be successful and I restarted HA but, after the restart, not all the pages opened and the web interface was sometimes frozen and did not respond to commands.
After several attempts I downloaded and installed HassOs 12.2 and restored a working backup.
Once logged in everything seemed to be back to normal.

  • I updated some custom components;
  • I tried to install Core 2024.3.1 again but found myself in the same problematic situation in which the pages didn’t open at all.

So I reinstalled HassOs 12.2 again but, this time, I didn’t update the core and left version 2024.3.1

However, at the moment, I encounter several issues:

  1. All add-ons appear to not start:

but in reality (at least some) are working. For example Duck DNS with which I can connect remotely and, in the component register, I see the logs in green.

  1. Another thing to point out is that I have problems with templates that have always worked, like:

  1. I can’t install new integrations.

Could someone please help me understand:

  • What may have happened?
  • What could cause problems with templates, add-ons and the inability to install new integrations?
  • Why can’t I update to core 2024.4.3?

Thanks to those who want and/or are able to give me support

Did you try to reboot (not restart HA, reboot)

there are quite a few issues reported updating to OS 12.2, see (x86_64) HA OS doesn't boot when updating from 12.1 to 12.2 · Issue #3305 · home-assistant/operating-system · GitHub and others.

not sure if 2024.4.3 has anything to do with that, but might not hurt to check the Github repo
tbh, this withheld me from trying…

rebooting the system solved the problems with add-ons and integrations installation.
I have now updated to core 2024.4.3

However, a series of problems remain, in addition to errors with the templates:

Has anything changed in the most recent versions of the OS and core that can generate these problems?

Thanks again