Problems when installing on ubuntu 14.04

Dear all,

I am trying to install but I get this error

curl -sL | bash -s
jq: Unknown option -e
Use jq --help for help with command-line options,
or see the jq documentation at …
(23) Failed writing body

I find no clues in the internet to try new things… could please someone help me here? Thks!

Hi @fempe, Welcome to HA.

I think jq on 14.04 is too old and has no -e option.
Maybe this helps?
I’d recommend installing it on the latest ubuntu. Maybe it’s not the only problem you will see.

Don’t use the latest version of Ubuntu, as it only has 9 months of support, use 16.04 which is supported until 2021.

1 Like

great, thks! I was able to update jq to 1.5 and seems it Works, but when installing now I get this error:

bash: line 108: /usr/bin/hassio-hc: Permission denied

I am working with an admin user , when I execute “cat /etc/passwd/ | grep user” I get user:x:1000:1000:Ubuntu:/home/user:bin/bash


working in root mode I can get this solved, but get this new issue:

bash: line 133: systemctl: command not found

so I will try to upgrade to 16.04…

Its because old versions of ubuntu (before 14) use upstart not systemd.

Agree with @cariboo to go with 16.04.

already uprgaded and I have this situation:

root@homeassistant:~# curl -sL | bash -s
[INFO] Install supervisor docker
[INFO] Install generic HostControl
[INFO] Install startup scripts
[INFO] Init systemd
[INFO] Start services
root@homeassistant:~# hass --open-ui
No command ‘hass’ found, did you mean:
Command ‘sass’ from package ‘ruby-sass’ (universe)
Command ‘pass’ from package ‘pass’ (universe)
Command ‘ass’ from package ‘irpas’ (multiverse)
hass: command not found

you should open a browser to URL http://your ubuntu machine IP:8123

thanks! I found my last (and silly issue), I am running a VM on azure and my ports were not open… now it Works thks!

I’m interested: what is your use case for cloud hosting your HA instance?
I would assume it makes getting sensor data from your house to HA probematic… (VPNs, routing etc)

I am starting to play with this platform and I do not have yet a physical server or RPi3. By the way, I am moving my family to another country, I do not want to trust on a single point of failure like RP3 or server, they may suffer some accidentaly shutdown and I will be lost… so I guess that by connecting the devices to the cloud I will have more availabiliity (I hope)

then in the future I want to play with machine learning capabilities of Azure and predict some behaviour, just for learning.

Your internet connection could be a single point of failure.
Unless you have redundancy - e.g. DSL/Fiber and 4G
Reduandancy and high availability in home is something I am hearing more and more…

Im getting the same “Permission Denied” on bash line 108 and I can’t wrap my head around the problem, I am running with admin privileges that God himself doesn’t even have!! this is frustrating

When I cat the passwd file and grep out for user I don’t get any entries; did I miss a step where I should have added a user for bash to use?