Problems with 0.66.0 after adding configuration (Netatmo)

As mentioned in another post, I had a problem when updating from 0.65.6 to 0.66.0 getting into the web interface. So I reflashed my microsd with a fresh copy. Started fine. Now when I add my configuration file (which has worked for the last many versions) I get :

panic: interface conversion: interface is nil, not string

goroutine 1 [running]:
panic(0x2c5f60, 0x1070b880)
/home/travis/.gimme/versions/go1.7.6.linux.amd64/src/runtime/panic.go:500 +0x33c, 0x24, 0x200, 0x0)
/home/travis/gopath/src/ +0x3c8, 0xd, 0x7ebfae6d, 0x7, 0x0, 0x0, 0x76000, 0x0, 0x0, 0x0, …)
/home/travis/gopath/src/ +0x308
/home/travis/gopath/src/ +0x540, 0x323754, 0x10778420, 0x0, 0x0)
/home/travis/gopath/src/ +0xf0, 0xd, 0x0, 0x0, 0x409d10, 0x1, 0x1, 0x300cfa, 0x2f, 0x0, …)
/home/travis/gopath/src/ +0x6b8*App).Run(0x107648c0, 0x1070a140, 0x3, 0x4, 0x0, 0x0)
/home/travis/gopath/src/ +0x8b0
/home/travis/gopath/src/ +0x108

when I run hassio homeassistant restart
Nothing has changed

So I have started with a blank configuration.yaml and added things back in one by one. It looks to be the Netatmo component causing the issue. Has anyone had the same problem on 0.66.0 ?

It’s odd because for all of 0.65 Netatmo wouldn’t work. Then I updated to 0.66 and it started working again. I don’t think I did anything other than upgrade home assistant. But yeah something is wacky with the Netatmo component

Which Netatmo product(s) do you have in use?

Thermostat and weather station. I rolled back to 0.65.6 and my config works fine.

I am on 0.66.0b2 and at least the thermostat works fine here. I’ll update later this evening and get back to you.

I have just the weather station but I was getting dependency errors if that helps. Seems to have fixed itself when upgrading this time but I expect it will break again.

1 Like

0.66.0b2 worked fine for me also, it was just upgrading to the final. I see they have bug fixed some things on 0.66.1 so I may try that later

1 Like

I just upgraded to 0.66.1 and the Netatmo Thermostat component is still working fine.

Well I went to the 0.66.1 version and lost the web access again with the same error. Rolling back to 0.65.6

What do you mean by “web access”?

Access the the frontend / GUI from a web browser, SSH / samba works fine.

How long did you wait after upgrading and restarting?

Approx. 2 hours 1st time.

Oh, ok, that is a long time. Sorry for asking but sometimes people are just impatient. 2 hours is definitely too long and might be a bug.

Checking my Pi-Hole server, it is being spammed by requests to from hass. Not sure what to try now . . .

Tried a new SD card, things seem to be working better !
It would work partially then things started to break after a full config. was put onto it. Bit odd that no-one else was complaining. Thanks for the tips.

And it’s broken again ! Spammed out the Pi-Hole server again before crashing. Back to 0.65.6